I am setting up membership to protect content on a specific

I am setting up membership to protect content on a specific page, when membership is activated that page often will not load - it just displays as a completely blank browser page. (Sometimes it load in some browsers and not in others- and that's not a constant - i.e. it will load in safari but not in firefox or vice-versa).

As this is the page ppl are registering to see, and as I'm ready to start doing press for this project - I need a fix!

Thanks!

  • Vaughan
    • Support/SLS MockingJay

    Hi @kathrynjones,

    That's strange, membership doesn't usually cause a whitepage on specific pages that are protected. Could you post a URL to that page so I can take a look?

    Also if you could grant support access in the Dashboard plugin. Dashboard > wpmudev > support > support access

    Can you also quickly switch to the default twentyfourteen theme & see if you still receive the whitepage then?

    Are you protecting the whole page using access rules? or are you using Level specific shortcodes to just protect specific parts of a page like below.

    [level-premium]Protected content here[/level-premium]

    Thanks

  • kathrynjones
    • Site Builder, Child of Zeus

    So following is only a partial response -

    Firstly - the WPMU dashboard - It is not showing up on my sidebar. Back story - while working with the membership plugin I did a test membership, which then changed my login access level, blocking me from the WP dashboard almost entirely. I had to go into PHPmyadmin and create a new admin login for myself - evidently a common problem - since that time the wpmu dashboard, while activated, is not showing up on my wp-admin dashboard. How do I fix this?

    Secondly - I figured out that the issue is not the protected page, but the registration page - the protected page was forwarding to the registration page - which was blank in firefox.

    http://virtualarts.tv/tempesttuesdays/register-for-tempest-tuesdays/

    Before I play around with skins and themes I'm going to try to protect content via short code rather than the whole page - i'll let you know what happens -

    In the meanwhile, how do I fix the WPMU dashboard? It obviously has something to to with permissions and my login - but now sure how to solve...

  • Vaughan
    • Support/SLS MockingJay

    Hi @kathrynjones,

    The dashboard plugin is only visible to the admin that installed it, so if you have created a new admin account, this will be the reason.

    You can gain access by adding the following to wp-config.php

    define('WPMUDEV_LIMIT_TO_USER', '1');

    change the 1 to your new admin accounts user ID.

    Hopefully that should get it back.

    On your second issue, no problem, let us know if you need any further assistance on this or if you have any further issues.

    Thanks

  • kathrynjones
    • Site Builder, Child of Zeus

    thanks.... adding that line served me a blank page instead of the wp-admin page - so had to upload the back-up without that line -

    Does it need to go in a specific place in the wp-config file?

    All of these problems stem from testing the membership registration - this is ridiculous....

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.