I am struggling to install the latest Multi-Domains plugin update

The dsahboard tells me there is an update available (1.2.2) but i cannot update. Selecting and updating gives me:

An error occurred while updating Multi-Domains for Multisite: Update package not available..

And downloading and then uploading gives me:

Unpacking the package…

Installing the plugin…

The package could not be installed. No valid plugins were found.

Plugin install failed.

What should I do?

Thanks
Simon