I am trying

Hello, I am trying to embed a video to be without watermark, besides the tutorials of you and very fast, I can not see and understand right.
please help me! how do I do that? I want to leave my video like this: http://prntscr.com/e75upf

    Rupok

    Hi Râmed,

    Thanks for asking. But I'm not sure what you are exactly trying to achieve. You can put our tutorial videos on your pages by using the shortcodes available at the bottom of your settings page. And the output will be the same as your screenshot. Please check the attached screenshot for reference.

    Are you trying to embed other videos on your site in the same way? Or are you not getting your tutorial videos showing in the same way?

    We can provide you best solution if we are clear about your requirements. Can you please add a little more details so we become clear and can provide exact solution? I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

    Nithin

    Hi Râmed,

    Hope you are doing good today.

    I suppose you only want to remove the player controls? I did try to check whether any CSS could help, but it doesn't seem to work. I'm checking this with the developer to see whether we could have a quick workaround regarding this.

    Please do note that developers work round the clock with many critical issues, and hence have a slow response time. Either myself, or the developer will keep you posted regarding this asap.

    Kind Regards,
    Nithin

    Panos

    Hi Râmed ,

    Of the screenshot I understand you want to remove the player controls.

    The player is included in an iframe so I'm afraid there is no way to modify the content as this action is not allowed be browsers.

    What we can do is access fetch the video with a different approach.

    First you will need to modify one line in file wp-content/plugins/wpmudev-videos/wpmudev-videos.php, line ~283 from

    return '<p class="wpmudev_video"><iframe src="' . $this->create_embed_url( $video ) . '" frameborder="0" width="' . $width . '" height="' . $height . '" webkitAllowFullScreen mozallowfullscreen allowFullScreen></iframe></p>';

    with:

    return '<p class="wpmudev_video"><iframe src="' . admin_url( 'admin-ajax.php' ) . '?action=wpmudev-custom-source&video=' . $video . '" frameborder="0" width="' . $width . '" height="' . $height . '" webkitAllowFullScreen mozallowfullscreen allowFullScreen></iframe></p>';

    Then create a mu-plugin ( please read here about mu-plugins ) or your theme's functions.php file and add the following snippet:

    add_action( 'wp_ajax_wpmudev-custom-source', 'wpmudev_custom_video_source', 10 );
    add_action( 'wp_ajax_nopriv_wpmudev-custom-source', 'wpmudev_custom_video_source', 10 );
    
    function wpmudev_custom_video_source(){
    
    	global $wpmudev_vids;
    
    	if( ! isset( $_REQUEST['video'] ) ){
    		return;
    	}
    
    	$video = $_REQUEST['video'];
    
    	$response = wp_remote_get( $wpmudev_vids->create_embed_url( $video ) );
    
    	if ( is_array( $response ) && ! is_wp_error( $response ) ) {
    
    		$body = str_replace( 'controls', 'autoplay', $response['body'] );
    
    		echo $body;
    
    	}
    
    	exit;
    
    }

    Note that I added autoplay as there will be no way to start the video playing. Also once it starts to play there is no way to make it stop

    Hope this helps!

    Cheers!