I am trying to view my site remotely using the ip address.

I am trying to view my site remotely using the ip address. It is a developmental server. I only get text on the page. locally it works, even when using the ip address. is there a setting to exchange the localhost to the ipaddress.

Thanks,

Robert

  • Adam Czajczyk

    Hello Robert,

    I hope you're well today and thank you for your question!

    I think the issue here is that WordPress is unable to load some resources (such as CSS) when accessed via IP address. This works locally because your local server "knows" that you're accessing it locally, therefore is able to translate all URLs/paths as necessary. This however is not a case when you're accessing the site from outside.

    As you are able to access it (even though it's not working fine), I assume that you're using a static (dedicated) IP, is that right? Or are you using some sort of Dynamic DNS service for this? Is you local server behind NAT or is it directly accessible from outside?

    The first thing I'd try would be to go to your site's dashboard to the "Settings -> General" page and then replace localhost with an IP in "WordPress Address (URL)" and "Site Address (URL)" and give it a try. If this doesn't work for you, please replay to my questions above.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Robert!

    It seems then we're "half a way there" :slight_smile: By "no images" you're referring to images in posts or images that are part of layouts? Is there no images whatsoever or just some are missing?

    The images that belong to content (such as images in posts/pages, featured images) should work because after you change Site and WordPress Address these should be updates. You may need though to first:

    - clear and switch off any caches that you're using (both on-site and server-side)
    - re-save permalink settings (on dashboard's "Settings -> Permalinks" page)
    - then enable cache again.

    As for images that are parts of layout it may be necessary to re-check theme's CSS files and manually update paths so for example

    background: url('localhost/wp-content/theme/mytheme/image.jpg');

    becomes

    background: url('168.12.33.44/wp-content/theme/mytheme/image.jpg');

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.