I am unable to design my own blog page.

Dear wpmudev team,
I have one blogpost displayed in the blog element on my mane page. Now I wanted to build a separate blog page with sidebar, search and all the good stuff.
The problem is, that upfront seems to be using a standard blog page that is resistant to change. It is not shown in the page list and I am unable to delete it.
What I have done to resolve the Problem.
Blog1: I have tried to find the standard blog page to remove it but could only locate the page i have created.
Blog2: the strange thing is that every time I add another blog page the number in the link grows by one. So this is my third try to remove the blog page and create a new one controlled by me but upfront takes control of that page right away. When I try to remove the "-3" in the address Line when viewing the Page upfront just adds it back. The is no 404!
Blog3: I made sure that the standard blog page is set to the page i have created.
Blog4: I tested whether I can find the standard Page in upfront, but could only see the page that i have created.
Blog7: I edited the blurry looking standard page to see if I had any control over it. I did save!
Blog8: When opening the only existing blog page, everything is back to how it was before I changed it.

I am sure that I am just missing something trivial but steel need your help.
Hope you are having a great day
Vassi

  • Predrag Dubajic

    Hey @Vassi,

    Hope you're doing well today :slight_smile:

    First thing you would want to do is revert to Static Page option in Settings > Reading since the Upfront actually functions in different way than standard WP themes.

    After that you should created standard page using Upfront edit mode and add Posts element, set post list and now you can customize your post list, resize that region to add sidebar and do other awesome stuff :slight_smile:

    Let us know if you need more help with this.

    Best regards,
    Predrag

  • Vassi

    Hi Predrag,

    thank you! I went into the Settings > Reading and just did not choose anything for the blog page. Then everything started to work just fine. I had selected a static frontpage before, but that did not have any effect on the strange blog page behavior.
    I tested it by selecting a random page as the blog page and that page was changed to the standard Spirit blog template. After removing the selection the page was restored to its previous look and feel.

    So problem is resolved. THX!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.