I am using a theme from a different publisher. Up until

I am using a theme from a different publisher. Up until downloading the most recent update to the custom sidebars plugin everything was working fine, but now the sidebar is missing on our home page. Custom sidebars are working on other pages/posts and I have tried swapping different sidebars on the home page.

I upgraded to custom sidebars pro in hopes of fixing the issue, however the home page sidebar is still missing. This issue is live on a site that is going to be getting a lot of traffic very soon so a quick solution would be much appreciated!

  • Tyler Postle

    Hey John,

    I would be more than happy to help you out here :slight_smile: welcome to the WPMU DEV Community!

    Just looking at your site I can see you have some Js errors, one is coming from an embedded player, can you remove that player from the home page?

    Also, do you have any caching plugins installed? Often those can mess with the javascript on a page.

    If you temporarily switch out to the default 2014 theme, does the sidebar show up? We just want to narrow down where the conflict is happening :slight_smile: whether it's a theme conflict, conflict with another plugin, or other.

    Looking forward to hearing back John!

    Cheers,
    Tyler

  • John

    Hi, after install the wpmu dev plugin my site is almost completely broken. The admin is no longer accessible. I am trying to deactivate each plugin manually until i can get back into the admin and figure out what happened. If you have any suggestions they would be appreciated.

    All I wanted was to fix the sidebar, instead was forced to download a plugin that did not fix the issue and completely broke my site

  • Tyler Postle

    Hey John,

    Sorry to hear about the issue here, let's get your site back up shall we :slight_smile:

    Here are some good tips on troubleshooting an 500 server error: http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-internal-server-error-in-wordpress/

    I re-call seeing a Js 500 internal server error from one of the Js files in your wp-admin folder when I checked your site earlier.

    Have you had any luck getting it back up after deactivating plugins?

    When it comes to a 500 server error, it is also a good idea to contact your web host as they will be able to let you know about the activity that happened right before the site went down, this will help with the troubleshooting.

    Best way to deactivate your plugins when this happens is through FTP, simply re-name your plugins folder and it will soft-deactivate all of them. Then check to see if your site is up.

    Let me know what your status is on this John, I'll be keeping a close eye on this thread :slight_smile:

    If you want me to take a look at anything, your .htaccess or plugins, then send me your FTP and WP info privately through our contact form: https://premium.wpmudev.org/contact/

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Look forward to hearing back!

    Cheers,
    Tyler

  • Tyler Postle

    Hey John,

    Glad you got the site back up :slight_smile:

    You mentioned that it use to work, it worked before updating the custom sidebars plugin?

    Did you delete the free version then download/install the paid version through the WPMU DEV dashboard? Before your site went down of course.

    There could have been a conflict with the upgrade.

    If you also try temporarily switching to the default 2014 theme then that will rule out any possible theme conflicts.

    Talk to you soon!

    Cheers,
    Tyler

    • John

      Hey Tyler, thanks for sticking to this thread.
      first off I'd like to clarify that it wasn't the wpmu dev dashboard that caused the error, but some rogue js inserted accidentally by another member of my team...(sigh)

      to answer your question, i updated the free version which caused the break. notably a few other users are experiencing the bug with their own themes after the upgrade:
      http://wordpress.org/support/topic/sidebar-not-displaying-on-static-main-page
      I thought that maybe I needed to upgrade to preserve the functionality so I forked up the$20 and downloaded the wpmu dev panel. tbh I'm fine sticking with the free plugin so long as it works like it did before the most recent patch. Is your technical team aware of this bug in the update? Is there a temporary fix I can apply? As I mentioned before this is our production site so time is of the essence!

  • Tyler Postle

    Hey John,

    Thanks for linking to the thread and for bringing this bug up, I have reproduced it in my own install as well, and have reported it to the developer :slight_smile:

    Bug fixes are always put at top priority.

    In the meantime, if you need it resolved right this second, you could try reverting back to the previous version. You can download the previous versions by going to the plugin page: https://premium.wpmudev.org/project/custom-sidebars-pro/

    Going to the changelog, in the right sidebar and clicking on any version number you want to download. Thanks for all your patience here John!

    Cheers,
    Tyler

  • Philipp Stracker

    Hi @John,

    thanks for reporting this issue - actually we were not aware that people were placing custom sidebars on a static front-page using the sidebars metabox... well, until today.

    The intended solution to put a custom sidebar on the front-page is displayed in the attached screenshot: Go to Widgets screen > Edit the Sidebar Location > Select "Archive: Front Page".
    Note: This option was buggy until the update to 2.0.9.2 and now works as intended. So in case you are using 2.0.9 then chances are, that you'll have to update to latest version before the "Archive: Front Page" option works for you.

    However, to maximize compatibility we will publish an update in a few minutes - in version 2.0.9.3 you can use *both* options ("Archive: Front-Page" OR the page metabox; if both options are set, then "Archive Front-Page" takes priority)

    Please let us know if the update works as expected :wink:

    p.s. In case you need to know why a certain sidebar is displayed/not displayed we include a debugging feature since 2.0.9.1:
    Open your website with URL "?cs-explain=on" and you will see some additional information in the bottom of the page that explains why a sidebar is used. e.g. "http://www.babycakesnyc.com/?cs-explain=on" - use "?cs-explain=off" to turn it off again. This information is only displayed for you, nobody else will see it.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.