i am using openssl 1.0.2a-flips version and have done

i am using openssl 1.0.2a-flips version and have done a manual install of openssl 1.0.2d and remove the older version. when i using the command openssl version, it show me the new version. But there seem to be a dependency of apache to the older openssl, wen using this command, curl --head 127.0.0.1, it show "Server: Apache/2.4.16 (Unix) OpenSSL/1.0.2a-fips mod_bwlimited/1.4"