I am using the Hummingbird plugin and when enabling GZIP

I am using the Hummingbird plugin and when enabling GZIP Compression I get the error message.
"- Your server may not have the "deflate" module enabled "
I have contacted my hosting company who have assure me that it is enabled. I have also deactivated all plugins, except for WPMU Dashboard and Hummingbird and tried again and still receive the error message. This is true for all the sites that I to enable GZIP Compresson.

Thanks