I can't create

I can't create a backup with the snapshot plugin. Every time I try, it gives a server error.

  • viobru

    Hi, Chelsea!

    Hope you’re doing well today :slight_smile:

    I’m sorry for the inconvenience that you’re having on your site. Server errors when running a snapshot could be related to different settings of your server. To have a look at what could be causing the error, I’ll need some information about your site. Could you please send us an email with this?

    Subject: "Attn: Violeta" (Please use this subject line to ensure that it gets assigned to me :slight_smile: )
    - Server authentication credentials (username/password)
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Linkback to this thread for reference
    - Any other relevant URLs

    You can use our secure contact form here to send it (please, do not post this information in this thread since this is an open thread and could be accessible by anyone): https://premium.wpmudev.org/contact/#i-have-a-different-question.

    Many thanks in advance!
    Happy New Year! :slight_smile:

    Kind regards,

    Violeta

  • viobru

    Hi, Chelsea!

    Hope you’re doing great and sorry for the delay in response :slight_smile:

    I’ve been checking your site and I see that you have a max execution time set to 120 on it and Snapshot recommends to have this feature set to a minimum of 150, if possible. I also checked that your site is hosted with SiteGround (I also guess that it’s on a shared hosting) and I know that SG doesn’t allow to increase this value for shared hosting, so you may not be able to increase this value on your site.

    (If I’m wrong and your site is NOT hosted on a shared hosting, you can try increasing the WordPress memory and maximum execution time by following the instructions provided here (please try setting max_execution_time to 300 and memory_limit to 1024):
    http://docs.woothemes.com/document/increasing-the-wordpress-memory-limit/
    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
    http://codex.wordpress.org/Common_WordPress_Errors#Maximum_execution_time_exceeded)

    I tried to run a partial backup on your site (excluding the uploads folder) and I was able to, this is the file: snapshot-1515211280-180106-040120-16c45975.zip, which is 19.54MB (please note that this is NOT a complete backup of your site).
    I’ve also created another partial backup of your site, but this time including ONLY the uploads folder, this is the file: snapshot-uploads-folder-1515215180-180106-050620-645c2c82.zip, which is 1.2GB. I randomly checked the logs of this second snapshot and I could find some PDF and ZIP files that could be affecting the size of the /uploads folder:

    So I was going to check the uploads folder from your site to check if there’s any large file that could be causing this, but it seems that there’s no FTP host specified on the email that you’ve sent us. Could you please share this info or cPanel creds instead via our contact form? Please use the same steps I shared in my first post.

    Many thanks in advance!

    Kind regards,

    Violeta

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.