I can't enter text into my Hustle forms. It's also not displaying placeholders.

Haha, I like the "Hey, leave something for the question body" message.

I'm working on a website, and I've just installed the Hustle plugin. At the moment it's only displayed on one page until I can figure out what the problem is.

I can't enter text into the name and email fields, and the placeholders are not showing up on the fields themselves. The text on the sign up button doesn't show up either.

Although, if I click on a field and then hit tab on my keyboard, everything shows up. And then I can hit Shift+Tab to navigate through the fields, or I can click in them normally.

When I do type in the fields, the text is all the way on the left hand side, almost cut off. Meaning, if I enter my name and my name starts with M, the M is so close to the edge of the box that it appears almost cut off.

- Does anyone have any advice on fixing the issue with the form not being clickable & the placeholders not showing up?

- Is there a way to move the placeholders and the entered text to the middle of the field to leave some white space on either side?

- I don't know if it's just me, but the "Sign Up" font is a bit blurry. It's not sharp, and all the other text on the form kind of looks like that too, especially the "Please fill in the .."

- Is there a way to put some space in between the fields? I don't want them to be so close together.

Thank you so much. Sorry if this post isn't in line with the guidelines, please let me know if they're not. This is my first time posting here.

The page in question: http://bit.ly/2mc7IHt

Edit: I've tried all variations of the form (slide-out, pop in etc) and I've also tried it inside a widget. The same issues are present in all cases.

  • Rupok

    Hi Mustafa,

    So sorry for the inconvenience you are having. I could not regenerate these issue on my test site but I could not. So this is your site specific issue.

    - Does anyone have any advice on fixing the issue with the form not being clickable & the placeholders not showing up?

    Just to make sure no other plugin is causing this, specially caching plugins, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Moreover, can you please activate any default WordPress theme and check if the issue resolves? That will make sure if your current theme is causing this or not.

    - Is there a way to move the placeholders and the entered text to the middle of the field to leave some white space on either side?

    Yes. You can do this with the following custom CSS Code:

    .wpoi-element input {
      text-align: center;
    }
    .wpoi-hustle form .wpoi-element label .wpoi-icon {
      float: left;
    }
    .wpoi-hustle form .wpoi-element label {
      width: 100%;
      text-align: center;
    }

    You can add this to a theme's stylesheet, in a child theme, or using a plugin like My Custom CSS.

    - I don't know if it's just me, but the "Sign Up" font is a bit blurry. It's not sharp, and all the other text on the form kind of looks like that too, especially the "Please fill in the .."

    I just checked this in my Macbook Pro retina display but the texts you referred to, seems to be pretty sharp and clear to me. Not sure how it looks on other displays. But as these are font, should not be blurry IMO. Can you please check from a different display?

    - Is there a way to put some space in between the fields? I don't want them to be so close together.

    If your input fields are joined together, then you can make them separate from the display settings. Please check the attached screenshot for reference.

    If you already did that, and need more spacing, then you can use the following custom CSS Code:

    .wpoi-hustle .wpoi-fields-separated .wpoi-element {
      margin-right: 20px;
    }

    You can add this to a theme's stylesheet, in a child theme, or using a plugin like My Custom CSS.

    I believe, these will help.

    Please let us know the result of your tests. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Mustafa

    Thank you for the CSS fixes. I had the borders set up in the options, but they weren't being changed on the front-end.

    I changed theme before disabling any plugins, and the form worked fine. I didn't even realise that the fields had icons until I switched theme to twenty15. That's a shame. I will reach out to my theme developer, maybe I'll get lucky. I'm no longer in their support period so we'll see what they say.

    Also I would like to make a feature request please: I don't want to annoy the user with a pop up asking them to subscribe. I would like to be able to place a vertical (on the side) or horizontal (on the bottom) button that they can click to slide-out the form and sign up. That would be nice

    Thank you

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.