I can't get it to create a sitemap, I have even tried

I can't get it to create a sitemap, I have even tried to set the rootfolder to 777 for a while to try it.

I have the same plugin installed on http://webalvarez.com and there it works perfectly

  • Alexander

    Hi @WebAlvarez,

    Maybe there are some errors being generated. Can you try enabling WP_DEBUG mode and debug logging? To do this, just go to wp-config.php include this:

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true);

    You might already have a line for WP_DEBUG, so just make sure it's set to true. This will create a log file under wp-content/debug.log with detailed information.

    If you'd like to avoid end users seeing error messages, you can include this as well:

    @ini_set('display_errors',0);
    define('WP_DEBUG_DISPLAY', false);

    This will prevent errors from being displayed, but you can still find them in the log file. For information on this, checkout this wpmu.org article.

    Let me know what errors if any you are getting!

  • Alexander

    Hi @WebAlvarez,

    I'm sorry for not getting back to you sooner here.
    Is it possible that the file is being created, but you're just getting a 404? Could you check your .htaccess file (or nginx config) for any rules related to sitemap.xml? Also, use FTP (or a file manager) to check for the file's existence.

    If this doesn't help, it could be a plugin conflict. Can you try testing for a theme or plugin conflict? You can do this following the chart here: https://premium.wpmudev.org/manuals/getting-support/

    Once everything is deactivated, try deactivating and reactivating Infinite SEO in case this helps it regenerate the sitemap.xml file. Be on the lookout for anything that comes through WP_DEBUG throughout this process.

    Once we identify a conflict, we can look for a specific solution for it.

    Let me know how it goes!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.