I CAN'T GET THE PROSITES TO WORK

Ok,

I setup multisite on my wp. I went step by step.
When I finished, I did a test run - Got:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator and inform them of the time the error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

I called godaddy. They told everything looked fine on their end, to contact developer.
So I'm here now. The site is bookyourbarber.com

  • Jack Kitterhing
    • Code Norris

    Hi Charlie,

    I hope you are well today and thanks for your question.

    I've just been taking a look at this and it appears Multisite is broken before you get to Pro Sites.

    As when signing up for a multisite that all goes well, but then there's that internal server error when visiting the login page of the newly created site and the front-end has no style sheet loading.

    Can you send me FTP details and network admin login details to take a look at this please? Please send to contact(at)wpmudev.org with the subject line Attn: Jack Kitterhing

    Thank you!

    Kind Regards
    Jack.

  • Charlie
    • Flash Drive

    Hello,

    Thanks for helping. I will send what you asked for. Please give me a few hours, I'm at work at the moment, I have all those notes on my desk at home. So please give me until 4pm eastern time.

    Thank you for the help, I much appreciate...

  • Jack Kitterhing
    • Code Norris

    Hi there @Charlie

    I hope your well today and thanks for the sending across the information.

    I have just been checking this for you and there's a couple of things.

    On the main website, in settings > permalinks, you have day and name set, this is required to be postname for most plugins to function correctly, could you change that please? :slight_smile:

    Then, in your file structure, you have WordPress files in the root with a folder of byb, which it looks is where your website resides, but the issue with this your .htaccess has an extra part to it, where it looks your re-writing the root to /byb,

    On a single site install this wouldn't be a problem, but on a multisite install this can cause issue, I'd recommend changing the .htaccess back to default which is

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Could you try that for me and let me know how it goes? I'm here to help you :slight_smile:

    Thank you!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.