I can't install any plugin from WPMU Dev Dashboard. Get the error install package not available

I can't install any plugin from WPMU Dev Dashboard. Get the error install package not available.

I've had this issue since the day I signed up for the account at wpmudev.

I've read the forums, tried to figure out the problem myself, but no luck so far.

Cheers