i cant install the multi domain plugin. I want to give my

i cant install the multi domain plugin. I want to give my users the ability to choose between multiple domains for their website but i got error that plugin not works