I can't upload translation .po file

Hello,

I'm trying to upload since yesterday the French translation plugin file of Snapshot.

But I get this:

Whoops, this request has been Blocked!
This request has been deemed suspicious and a Possible attack on our servers.

Since I have not had a reply from contact@wpmudev.org I post my "claim" here.

I obviously understands the security problems, I am not at all surprised or offended.
We must say that I have been "very active" in recent days on WPMU and my IP (dynamic) is probably a little exotic ...

Anyway, if any of the staff can help me or accelerate the procedure so that I could, I would appreciate it!

Thank you.
Laurent.

  • Ash
    • WordPress Hacker

    Hello @lol

    I hope you are well today.

    Very sorry to know that you are having issues. Would you please post a full page screenshot of the error?

    Also, would you please delete browser cache and try again? Maybe from another browser?

    Please let us know.

    Cheers
    Ash

  • lol
    • The Incredible Code Injector

    Hi Ash,
    Thank you for your help.

    I think this is not an error caused on my side, the message is clear: "this request has been Blocked!"

    Anyway, I tried after clearing the cache and I tried with another browser, same story!

    Laurent.

  • Ash
    • WordPress Hacker

    Hello @lol

    I have talked to our sysadmins and the issue seems related to WAF (web application firewall) on cloudflare. One of our sysadmins is going to take a look and will fix the issue as soon as possible.

    Once the issue is fix, you will be updated :slight_smile:

    Cheers
    Ash

  • lol
    • The Incredible Code Injector

    Hi there,
    I saw that S H Mohanjith uploaded my .po file. What's now ?
    why can I not do it myself ? What was (or is still) the problem ?

    And... I'm not particularly eager for laurels, but I would like clarification that it is I who has translated ... :wink:

    Thank you!
    Laurent.

  • Vaughan
    • Support/SLS MockingJay

    Hi lol, I've asked our DB admin, to look into changing the user who uploaded the file to your user id, it could be a bit of time though before he gets round to it, but hopefully we can get this sorted for you.

    With regards to the actual issue, it's due to full paths being used in the translation file which needed to be changed.

    We will need to address this by changing the .pot file for snapshot plugin in future, so I have marked this as a bug for the developer to look into, hopefully this will then solve the issue in future.

    Hope this helps

  • lol
    • The Incredible Code Injector

    Ok Vaughan,

    Thank you for the clarification.

    Now it would be nice to keep us informed ... When can we rework the translations?
    Is the problem only for the Snapshot plugin? Only for the French?

    There should be an alert at the translations page, right?

    Laurent.

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    From what I can gather the issue was that 2 of the messages contained a path that was wrong /var/www

    From the developer.

    #: lib/snapshot_admin_metaboxes.php:563
    msgid "The exclude logic uses pattern matching. So instead of entering the complete server pathname for a file or directory you can simply use the filename of parent directory. For example to exclude the theme twentyten you could enter this one of many ways: twentyten, themes/twentyten /wp-content/themes/twentyten, /www-data/example.com/wp-content/themes/twentyten. Regular Expression are not allowed at this time."
    msgstr ""

    #: lib/snapshot_admin_metaboxes.php:2090
    msgid "Use this setting to create global exclusions. This means the excluded files or directories will be excluded automatically from all snapshot configurations. You can also setup exclusions specific to a single snapshot via the configuration screen. The exclude logic uses pattern matching. So instead of entering the complete server pathname for a file or directory you can use simply use the filename of parent directory. For example to exclude the theme twentyten you could enter this one of many ways: twentyten, themes/twentyten /wp-content/themes/twentyten, /www-data/example.com/wp-content/themes/twentyten. Regular Expression are not allowed at this time."
    msgstr ""

    So in the .pot file or translation string, for those 2 translations above, you simply need to change the existing /var/www so /var/www/example.com/wp-content/themes/twentyten. is changed to

    /www-data/example.com/wp-content/themes/twentyten. instead.

    It was just the /var/www/ causing it apparently. So if you need to do this yourself, for now, you will need to change those lines in the .pot file so they use /www-data/ instead of /var/www/

    Then also make the changes in the file snapshot_admin_metaboxes.php in both the lines mentioned above. But this will affect all translations not just french.

    This should probably be included in the next plugin update.

    Hope this explains it a bit more.

  • lol
    • The Incredible Code Injector

    Hi Vaughan,
    Thank you for taking the time to look back on the issue.

    If I understood ...
    If I have to modify the php code to complete the translation, I think it is better to stop.
    A sane person does not change the code of a WPMU plugin to get a good translation.

    I think it is better to wait for the next update. You will think of it at the time?

    I am still, despite the failure to finish and leave unfinished business, glad to have raised the issue.
    Moha is always credited with the translation ...

    Thank you.
    Laurent.

  • Vaughan
    • Support/SLS MockingJay

    Hi lol,

    Yes, you understood correctly :slight_smile: We will add this to the update, i've created it as a bug in the plugin, so the developer will be fixing it :slight_smile:

    With regards to Moha receiving credit, we can't change that apparently, but Moha will give you the rep points for it as & when they come in. If not, just message me or another staff & we'll get the points over to you anyway, so no need to worry in that regard :slight_smile:

    Hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.