I changed the permalink structure according to PC's

I changed the permalink structure according to PC’s directions here https://premium.wpmudev.org/forums/topic/how-to-change-network-default-permalinks#post-440253, now the new structure shows in the browser bar correct, however, I get “page not found” in the top tab next to the favicon and in the title. http://wpinstasites.com/test-new-permalink-structure/. Can this not be done on an existing multisite or only on a new multisite install before adding test sites and development?

I posted on that thread as well. Should I have created a new post or ask for assistance there? Just trying to understand correct protocol.

Thanks for your help – Jan

  • Alexander
    • DEV MAN’s Mascot

    Hi Jan, as you were not the original poster at the other thread, its ok to start one for yourself as this issue might be different for you site and different troubleshooting steps might be needed.

    So it looks like the your pages are being saved with the right links, but WordPress can’t find the post again later by that URL.

    First thing we can try is simply refreshing the permalinks. Go to your main site, then “Settings -> Permalinks” Then just click “save”

    This will tell WordPress to rebuild it’s permalink structure. Basically all it’s doing is removing the cached version of permalink rules from the database which might be incorrect, and rebuilding them from scratch using the rules provided by your various plugins and the theme.

    Let me know if this works. If you’re still having problems, would you mind explaining the steps that led up to this, and what you’re trying to accomplish? As this was more of a followup from another users question, it could be helpful to know the original circumstances of your issue instead

    Best regards

  • Jan
    • Site Builder, Child of Zeus

    Hi Alexander,

    Thanks for the quick reply and explanation. I used PC’s instructions,

    You can do that via Network Admin >> Sites >> Edit the Root site >> Settings >> Scroll down to Permalinks and define it there.

    I just used your instructions and went to the dashboard for the main site >>Settings >> Permalinks and set it there even though it showed correct, I saved again. It fixed it on the main site but is it possible to have the sub-sites use the same structure?

    Thanks again for your great help and explanations — I love understanding how this works, so appreciate the instruction. – Jan

  • Alexander
    • DEV MAN’s Mascot

    You’re welcome!

    It actually works a but differently, Mulsite did change the redirects and URL structure slightly, but permalinks are alway work on a per site basis. It’s basically a set of regular expressions that map portions of a URL to different variables in WordPress. The changes made for multisite just allowed for the blogname to be represented as either the first URL parameter or a subdomain, this doesn’t affect permalinks though.

    Best regards

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.