I configured multisite on my site. Whenever I try to access

Hi,

I configured multisite on my site.

Whenever I try to access my primary domain without the "www", it redirects to http://www.myprimarydomain.com/wp-signup.php?new=myprimarydomain.com

If type in "wwww.myprimarydomain.com", it shows my primary site normally, but if I leave out the "www", it redirects to signup.php.

  • Hiifons
    • Site Builder, Child of Zeus

    Hi,

    My site is http://www.talointra.fi

    I have purchased a ssl certificate so could this be causing the problem?

    .htaccess

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

  • Jack Kitterhing
    • Code Norris

    Hi there @Hiifons

    Thanks for the additional information, looking at this information, this is a subdomain install correct?

    In that case your .htaccess file is correct, in your wp-config.php

    where you have the define sub domain install true, can you change that to false and see if it works? This isn't a resolution, rather something that I'd like you to test if possible :slight_smile:

    With the SSL certificate which one did you purchase and is it configured on the domain yet?

    Thank you!

    Kind Regards
    Jack.

  • Jack Kitterhing
    • Code Norris

    Hi there @Hiifons

    Thanks for the additional information.

    It's doing that as it believes the domain isn't created, so it presumes you want to create that as a sub-domain if that makes sense? Can you try my above suggestion just for testing please?

    where you have the define sub domain install true, can you change that to false and see if it works? This isn't a resolution, rather something that I'd like you to test if possible :slight_smile:

    Could you please also send in the following please, so I can look into this further?

    - In the subject field add "Attn: Jack Kitterhing"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    Thank you!

    Kind Regards
    Jack.

  • Jack Kitterhing
    • Code Norris

    Hi there @Hiifons

    I hope you are well today.

    No problem, I did receive the details and have spent a while taking a look at this issue, if you change this

    define('SUBDOMAIN_INSTALL', true); to this define('SUBDOMAIN_INSTALL', false);

    It then works, could you disable SSL and give me database access please so I can take a further look at this issue please?

    Thank you!

    Kind Regards
    Jack.

  • Jack Kitterhing
    • Code Norris

    Hi there @Hiifons

    I hope you are well today,

    I've been trying to login to both your database and FTP yet neither will work, could you double check that the user details you have sent through are indeed correct?

    Also another interesting thing I found was, the address you gave me starting with kilo, that redirects to the signup page as well, which is rather odd, do you have a cPanel etc I could log into and take a look?

    Ok so wp thinks I am trying to access a subdomain when I enter the url without the www. So this is default behaviour but how can it think that it is a subdomain?

    I'm not 100% sure what is going on here yet, so far it's looks like it's one of two possible options, the SSL is mis-configured or the database has a value that it shouldn't, would it be possible to contact your host and ask them to deactivate SSL for testing purposes?

    Thank you!

    Kind Regards
    Jack.

  • Hiifons
    • Site Builder, Child of Zeus

    I contacted the service provider and they answered the following:

    "Your site answers without the certificate at http://talointra.fi/. Only when using the https:// prefix it uses the certificate.

    Removing the certificate would mean the we would have ti dosable the HTTPS port 443."

    I have forced SSL in my wp-config file. Should I remove those?

  • Jack Kitterhing
    • Code Norris

    Hi there @Hiifons

    I hope you are well today, thank you for the additional information,

    I have forced SSL in my wp-config file. Should I remove those?

    If you could remove them please and then see where we are, if it works then or not :slight_smile:
    Have you setup the wildcard sub domain at your hosting provider?

    To send the login details you can send them through our contact form
    - In the subject field add "Attn: Jack Kitterhing"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    If you are having problems with the contact form you can send them to contact(at)wpmudev.org please make sure the subject line is Attn: Jack Kitterhing and all details are included :slight_smile:

    Thank you!

    Kind Regards
    Jack.

  • Jack Kitterhing
    • Code Norris

    Hi there @Hiifons

    I hope you are well today, sorry for the delay on this.

    I missed your previous response, I'm afraid I still can't access this, do i have your permission please for me to see if another member of staff can access it, just so I can see if it's my PC for some reason?

    Thank you for your continued patience.

    Kind Regards
    Jack.

  • aecnu
    • WP Unicorn

    Greetings Hiifons,

    Thank you for the input and starting form the beginning I checked the site and looking over the original post it is my opinion that the site was configured incorrectly from the beginning using the www in the domain when the site was set up.

    This www. has thrown the whole MultiSite off since with the current configuration when adding a sub site it would be sub.www.yourdomain.com and this will not work nor resolve.

    What needs to happen is when the site is created, i.e. WordPress installed only the TLD is used to address the site i.e. domainname.com

    WWW is not a domain or part of a regular domain, it is indeed a sub domain designation both by DNS and reality.

    WWW is an outdated way to indicate world wide web. However, if I tell someone domain.com and they do not know that I am referring to the internet well ....

    But in the "old" days of the internet this was indeed the practice.

    Therefore to straighten this out you will want to re-install the WordPress installation and when calling it up in the browser to install after FTPing the files, use just the TLD and it should all work forward from there i.e. http://yourdomain.com ... http://talointra.fi/

    As demonstrated in the WordPress codex:
    http://codex.wordpress.org/Before_You_Create_A_Network

    First Graphic in the post in the codex:
    http://codex.wordpress.org/File:sites-edit-site.png

    That should do the job for you going forward and when using www it will resolve to just the TLD but it will indeed resolve correctly and sub sites can also be resolved correctly.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.