I create new site (subdomain) from my main site. The 404

I create new site (subdomain) from my main site. The 404 error occurred when I click Dashboard, and when I checked the file inside the new site folder it has only 2 files. What do I do wrong? Could somebody help me out? I have 3 screen shot to support this message.

Kindly regards,
Suhartono Kusumo

  • Michael Bissett
    • Recruit

    Hey @Suhartono, hope you're doing well this evening! :slight_smile:

    Did you make sure to set up a wildcard subdomain? When a subsite gets created on a subdomain based Multisite, you should be seeing a fresh site there (with one of the default themes, like Twenty Fifteen), and not a directory listing.

    For the "barneast" site, it looks like you created a subdomain for that inside of HostGator, you'll want to delete that subdomain.

    Here's a guide from HostGator on wildcards:

    http://support.hostgator.com/articles/hosting-guide/lets-get-started/dns-name-servers/wildcard-dns-what-is-it-and-how-do-i-use-it

    You'd want to have a wildcard subdomain set up, like this:

    *.suhartonokusumo.com

    Hope this helps! :slight_smile:

    Kind Regards,
    Michael

  • Suhartono
    • The Incredible Code Injector

    This what I did to my domain name mysite.com:
    Pointed DNS to : dns1.example and dns2.example.com same structure as the DNS for example.com. The subdomain is really working well now. But I had a problem with mysite.com. Because, when I typed in browser mysite.com the white blank page show up. That's it nothing else, no error no nothing. Just white blank page. Could somebody help me out please?

    Kindly regards,

    Suhartono Kusumo

  • Michael Bissett
    • Recruit

    Hey @Suhartono,

    I should note that we do take threads here in order from oldest to latest, so it's not that I was ignoring your request here, it's just that there were other threads that members opened further up in the queue that I had to address first. :slight_smile:

    Now my next move is to assign the domain name to my new subdomain. Example: site1.example.com to become mysite.com, how do I do that?

    So you're wanting to assign a domain to a subsite on your network, correct?

    For something like this, you would want to use our Domain Mapping plugin to help with that:

    https://premium.wpmudev.org/project/domain-mapping/

    Can you try using that to map the domain to your subsite instead? :slight_smile: You can check out the usage instructions over on the project page by clicking on the "Usage" tab there.

    Please advise,
    Michael

  • Michael Bissett
    • Recruit

    Hey @Suhartono, glad to hear you got this sorted out. :slight_smile:

    I seem to recall a provider (not certain who it was) not providing wildcard subdomains unless you were at a certain level, perhaps your host is like that here? Usually though, wildcard subdomains are available with hosting providers (an example of a provider that's been mentioned here in the forums would be Surpass Hosting).

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.