Domain mapping does not redirect to mapped domains

I created a subdomain (www.maindomain.com/subdomain) and mapped four domain names to that subdomain (basically the subdirectory is the ".de" version of the ".com" maindomain, that is "maindomain.de").

Anyhow, the mapping does not redirect: No matter what URL I enter (any of the mapped domains, "maindomain.de" or even "maindomain.com/subdomain") - I always end up on "maindomain.com", the main domain of the multisite...

The only way to get a glimpse of the subdomain's frontend is when I go to the design section of the backend and choose to "customize" the theme. Any other try to access the frontend ends on "maindomain.com"...

Thanks for ideas how to solve this.

  • mynym
    • Site Builder, Child of Zeus

    Hi Predrag
    Thanks for your reply to my issue.

    I checked the setup and found out that there were copies of sunrise.php in all directories: wp root directory, wp-content and the domain-mapping plugin. I removed all copies except the one in the wp-content directory, but with no effect.

    I also noticed that the sunrise.php file was a different size compared to my other multisite installation. So I tried the copy from the other site that works fine - no effect.

    Finally I downloaded the plugin again and copied all the files via ftp (no uninstall/re-install, just overwriting everything) - again, no results, the problem stays.

    One more thing: I took a look at the sunrise.php file and found a path to a directory that does not exist in my file structure:
    ` "md_sunrise" => defined( "WP_PLUGIN_DIR" ) ? rtrim( WP_PLUGIN_DIR, '/\\' ) . "/multi-domains/inc/sunrise.php" : dirname( __FILE__ ) . "/plugins/multi-domains/inc/sunrise.php"

    There is no "/multi-domains" directory in the "plugins" directory. Might this be an issue...?

    Thanks for your help,
    Best, Wolfgang

  • mynym
    • Site Builder, Child of Zeus

    OK, here are some more news from experiments I made to figure out what goes wrong here. It seems like I have the mapping-but-not-forwarding-issue only with some domains. I tried several other domains, including .ch and .de domains, they all work fine. All are registered at the same registrar and have the same DNS settings.

    It if comes to the domain names that do NOT forward correctly, there is only one difference I can come up with: Originally, they had been listed as subdomains at my hosting provider, configured to redirect 301 to the main domain. After setting up the multisite, I first switched off the 301 redirect (but kept email forwarding alive). Meanwhile, I even completely removed the domains as subdomains from my account. In addition, pinging the URLs in question provides the right, dedicated IP address of my multisite installation, and adding mapping gives a "valid" on checking.

    I still do not understand why some domains do work, and others don't. Maybe the information above gives someone an idea on where to look for the cause of this problem - Thanks for your assistance!!

  • mynym
    • Site Builder, Child of Zeus

    The problem disappeared. I checked with my hosting provider, and asked if any of the redirects would still be in place. He told me he had no issue and the domain mapping worked for him - and from that moment on it also worked for me. Mmmmhhh... Summary: No idea why it did not work, no idea why it works not, but at least it works.

  • Patrick
    • Support Monkey

    Hi there @mynym

    Thanks very much for your patience on this issue as we deal with an inordinately large number of support threads.

    The first thing that comes to mind with these issues is DNS propagation.

    If you had made changes to 301 redirects and "A" records, propagation of all that could have taken awhile. It can actually take up to 72 hours.

    So, if you had been trying to access those mapped domains right after having made those changes, it could very likely have been due to the changes not having fully propagated yet.

    But I'm glad to hear that things appear to be working correctly now.

    Oh, and that /multi-domains line in the plugin is perfectly normal. That refers to our Multi-Domains plugin and ensures that the correct sunrise.php file is used.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.