I dont understand why Market theme is not working

1. This is the error I get: FrameMarket does not have styles built in please use a child theme

2. Warning: join() [function.join]: Invalid arguments passed in /home/content/35/10236835/html/e gift shop/wp-includes/post-template.php on line 389

class=””>

3. Also I want to install product plugin and I got this>>>

Installing Plugin from uploaded file: 154035_product-3.2.1.zip

Unpacking the package…

Installing the plugin…

The package could not be installed. No valid plugins were found.

Plugin install failed.

Return to Plugins page

So I do not Know what to do, would you please help???