I encount theirs

Hi,

I encount theirs errors:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; WDS_Metabox has a deprecated constructor in /home/quartierchinois/public_html/wp-content/plugins/wpmu-dev-seo/wds-files/wds-core/admin/wds-core-metabox.php on line 3

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; WDS_Taxonomy has a deprecated constructor in /home/quartierchinois/public_html/wp-content/plugins/wpmu-dev-seo/wds-files/wds-core/admin/wds-core-taxonomy.php on line 3

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/quartierchinois/public_html/wp-config.php:1) in /home/quartierchinois/public_html/wp-content/plugins/custom-sidebars/inc/class-custom-sidebars-explain.php on line 55

  • Tyler Postle

    Hey Quang Duc TA,

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; WDS_Metabox has a deprecated constructor in /home/quartierchinois/public_html/wp-content/plugins/wpmu-dev-seo/wds-files/wds-core/admin/wds-core-metabox.php on line 3

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; WDS_Taxonomy has a deprecated constructor in /home/quartierchinois/public_html/wp-content/plugins/wpmu-dev-seo/wds-files/wds-core/admin/wds-core-taxonomy.php on line 3

    You don't need to worry about warnings like this as they are more for the developer - it could mean that there will be issues in the future, but I'm passing this onto the developer to ensure the deprecated methods get replaced before that happens :slight_smile:

    In the meantime, make sure this is in your wp-config.php:

    define('WP_DEBUG', false);

    Yours might say "true" right now, just change it to false as those warnings/errors should be hidden unless you turn on debug.

    Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/quartierchinois/public_html/wp-config.php:1) in /home/quartierchinois/public_html/wp-content/plugins/custom-sidebars/inc/class-custom-sidebars-explain.php on line 55

    It looks like you must have some empty white space at the top of your wp-config.php file, make sure that you remove any white space at the top of that file, the first line should have

    <?php

    If you would like me to go in and fix this for you then send in your FTP and I'll get it sorted :slight_smile:

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    **If you keep support access active then no need to send in wp-admin

    Look forward to hearing back!

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.