Domain Mapping DNS Record

I figured out how to install and where to do the mapping.

I have a dedicated IP for my hosting. My question is do I keep the name servers the same as my registrars and just add the A record OR do I change the name servers to my hosting company too?

I also have access to cpanel and can forward and everything else.

Just wanting to have this as a future option for my users where they can do this on their own and I can explain the process.

I may be doing something wrong on my end. I was trying to map:

resistthe45.com to resisthe45.expathomesteading.com

And I get the “Domain Name is unavailable to access”.

I do have my domain name to LOCKED can that be the problem?

  • Dimitris
    • Support Star

    Hello Michael,

    hope you’re doing good and thanks for reaching us! :slight_smile:

    I have a dedicated IP for my hosting.

    I can see that you’re using a dedicated IP address as this can be seen in Domain Mapping setting page in network admin. Please keep in mind the following though:

    Dedicated IP: For using A Record setups, you need to ensure you have a dedicated IP. This IP would fall onto your multisite setup. i.e. when you enter the IP you see your multisite. This is known as the DocumentRoot for the IP, your host will be able to sort this quickly and easily.

    Reference: https://premium.wpmudev.org/project/domain-mapping/#product-usage

    Visiting your IP address seems to lead to another location/website though, instead of the main site of your multisite installation.

    Could you please set the DocumentRoot of your IP to be the same with the location of your WP installation? You may need to contact your hosting provider about this.

    I have a dedicated IP for my hosting. My question is do I keep the name servers the same as my registrars and just add the A record OR do I change the name servers to my hosting company too?

    This shouldn’t make any difference at all! Just keep in mind to have a single A record for each of your domains.

    I may be doing something wrong on my end. I was trying to map:

    resistthe45.com to resisthe45.expathomesteading.com

    And I get the “Domain Name is unavailable to access”.

    Please keep in mind that changes made in nameservers require 30min to 48h to propagate.

    Have it been some time passed already? Please advise!

    I do have my domain name to LOCKED can that be the problem?

    Could you please elaborate a bit more with me on this?

    Where and how have you locked your domain name? :thinking:

    Warm regards,

    Dimitris

    PS. I can see that you’re on trial with us, so please have a quick read on “How Free Trial Work” if not already. :slight_smile: https://premium.wpmudev.org/docs/getting-started/how-free-trials-work/

  • Michael
    • Design Lord, Child of Thor

    The IP is dedicated to my base website URL. For one of my sites I have it as a secure site and I asked it to point to a specific URL and they told me it didn’t matter. Hmmmm guess it does matter for this situation.

    Yes I am on a trial with you and I’m loving the options, glad for the trial so that I can get some issues solved first.

    I needed more coffee lol the domain is locked so that no one can move it, duh I thought it locked it from other things, yes more coffee thats it lol

    I’ll see if they can point the IP directly to that one domain, if not I’ll just get another dedicated IP address.

  • Dimitris
    • Support Star

    Cool, grab a coffee, contact your hosting provider and let us know! :slight_smile:

    Some extra piece of information that might further help you, coming again from usage tab of Domain Mapping plugin page here:

    https://premium.wpmudev.org/project/domain-mapping/#product-usage

    Why do I need a dedicated IP?

    You only need a dedicated IP address when using A Records to map your domain. This is because the domain being mapped needs to land on your WordPress multisite install and if it doesn’t then our plugin and WordPress won’t know when to map it.

    On shared hosting platforms, usually the sites IP address will fall on a landing page which is not related to your account in anyway.

    Nope that wasn’t it, the page still refreshes and nothing happens so what now sherlock?

    Another cause of this is the sunrise.php file, if you are running our Multi Domain plugin:

    https://premium.wpmudev.org/project/multi-domains

    Then you will find in the plugin folder an alternate sunrise file dm_sunrise.php you need to use this file. First rename it to sunrise.php and then upload it just like the original sunrise.php file in these instructions and that should fix you up! :slight_smile:

    Take care,

    Dimitris

  • Dimitris
    • Support Star

    Hey there Michael,

    I just had a better look and it seems that this documentation part about Multi Domain is a bit outdated, there’s no additional step that should be made here, I’m sorry for the false alarm here! :slight_smile:

    I’ve already notified our QA/Docs master Michelle about that so hopefully this will be corrected/removed pretty soon.

    Have a good one,

    Dimitris

  • Michael
    • Design Lord, Child of Thor

    I talked to my hosting company and since I have multiple sites in one hosting package the IP is pointed to the first one that I used to sign up with. I’d have to create a separate account in order to have the IP address pointed to expathomesteading.com

    Any idea how to make this work without adding another hosting plan?

    I tried the domain mapping, changed the A record to point to the IP and yet when I go to resistthe45.com I get the site URL that the IP points to.

    Maybe I should just create the multi site on that one instead and create a network inside the network.

    Unless you can think of something else :slight_smile:

  • Adam Czajczyk
    • Support Gorilla

    Hello Michael!

    There are two ways to make it work. One is by pointing A record to an IP but the IP

    a) has to be dedicated

    b) has to have “root folder” (aka “document root”:wink: set the way that it points to the folder where you WP Mulisite is installed; it cannot be any kind of forwarding and as a result when you type IP into your browser, a main site of your multisite should load.

    Second way is to simply use add-on domains. That doesn’t require dedicated IP at all. The way to make it work is to:

    1. Add the domain that you are going to use as mapped domain to your cPanel as an add-on domain

    2. While doing it make sure that the “root_folder” for that domain is set to be exactly the same as a “root_folder” for your multisite’s main domain

    If you set name servers for that “to be mapped” domain now to point to your name servers the domain should (after DNS propagates) load the main site of your Multisite too. You then should be able to map it to any of sub-sites.

    That second way (using add-on domains instead of IP) should work in your case so I think you should give it a try. Adding an “add-on” domain to be used for Domain Mapping is no different than adding any add-on domain to cPanel with an exception of “root folder” setting (see point 2 above) so just pay attention to that and it should solve the issue.

    If you have any further questions on this, let me know please.

    Best regards,

    Adam

  • Michael
    • Design Lord, Child of Thor

    Thank you sooooo much for the help. I created another hosting account for another site and the A name works great. On the one in question your suggestion helped to point the domain to the site.

    Though I personally don’t want to have to manually do this for other sites. I’ll switch this one over to an account for it’s own IP address to make it easier.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.