I get a 504 error when trying to access a site's dashboard on multisite

When I try to go to the dashboard of a site on my multisite network, I get a 504 error. I can access the main site and network dashboards just fine, but not the site in question. I recently updated some plugins and a theme- I was able to access the site prior to updating. I updated the theme via ftp and network activated it, but it does not appear in theme area in the "edit sites" area, wondering if this has something to do with it... Thanks for your assistance.

  • Milan

    Hello @isaac5,

    I hope you are having a good day and thanks for asking us. :slight_smile:

    Have you checked your site status after enabling debug mode ? If not then please go to your wp-config.php file and enable it by specifying WP_DEBUG constant's value to true.

    define( 'WP_DEBUG', true );

    After doing this are you able to see any error on your site ?

    Also it is good idea at this point that we take down plugin and theme conflict test to see it is not the real issue. So please follow this simple manual and take down those test,
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let me know how it goes. :slight_smile:

    Cheers,
    Milan

  • Isaac

    Hi Milan,

    I network disabled all plugins and themes, but still was unable to access the site.
    Below are the error messages when define( 'WP_DEBUG', true );

    Strict Standards: Only variables should be passed by reference in /home3/vanderij/public_html/wp-content/plugins/backupbuddy/pluginbuddy/_pluginbuddy.php on line 84

    Strict Standards: Redefining already defined constructor for class CustomGoogleSearch in /home3/vanderij/public_html/wp-content/plugins/custom-google-search/custom-google-search.php on line 46

    Strict Standards: Redefining already defined constructor for class CGS_Widget in /home3/vanderij/public_html/wp-content/plugins/custom-google-search/widget.php on line 20

    Notice: is_single was called incorrectly. Conditional query tags do not work before the query is run. Before then, they always return false. Please see Debugging in WordPress for more information. (This message was added in version 3.1.) in /home3/vanderij/public_html/wp-includes/functions.php on line 3792

    Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use
    __construct()
    instead. in /home3/vanderij/public_html/wp-includes/functions.php on line 3624

    Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use
    __construct()
    instead. in /home3/vanderij/public_html/wp-includes/functions.php on line 3624

    Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use
    __construct()
    instead. in /home3/vanderij/public_html/wp-includes/functions.php on line 3624

    Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use
    __construct()
    instead. in /home3/vanderij/public_html/wp-includes/functions.php on line 3624

    Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use
    __construct()
    instead. in /home3/vanderij/public_html/wp-includes/functions.php on line 3624

    Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use
    __construct()
    instead. in /home3/vanderij/public_html/wp-includes/functions.php on line 3624

    Notice: Undefined index: userhash in /home3/vanderij/public_html/wp-content/plugins/backupbuddy/pluginbuddy/lib/updater/updater.php on line 407

    Notice: Undefined index: username in /home3/vanderij/public_html/wp-content/plugins/backupbuddy/pluginbuddy/lib/updater/updater.php on line 408

    Let me know if you need any additional info, I've enabled support access on the WPMU dashboard.

    Thanks,
    Isaac

  • Adam Czajczyk

    Hello Isaac,

    Thank you for sharing debug.log content.

    The 504 error translates as a "gateway timeout error" meaning that the "gateway" (that could be a server serving your site or a server "in between" such as load-balancer or CDN's node) wasn't able to respond in time. This is often a symptom of overload so I accessed your site through support access that you granted and checked its WP settings.

    I've noticed that WordPress is granted only default 64M of memory so could we please start with a simple memory tweak? Please add following line to the "wp-config.php" file of your install:

    define('WP_MEMORY_LIMIT', '256M');

    This line should be placed above the "/* That's all! Stop editing.... " line in a file. Once it's added please empty/purge all caches on your Multisite and give test your install against the issue again.

    Let me know please if it helped.

    Best regards,
    Adam

  • Isaac

    Hello,

    I increased the memory limit in wp-config.php, and I am still unable to access the site. Additionally, after modifying wp-config.php, I got another error and could not access any of the sites:

    Parse error: syntax error, unexpected 'if' (T_IF) in /home3/vanderij/public_html/wp-config.php on line 110

    I removed the memory modification, and I can get to the dashboards of the other site on the network and the network admin page just fine. Seems like it might be a bigger problem...

    I also tried increasing the memory in .htaccess, but that was also unsuccessful and created other errors, so I removed it.

    Thanks,
    Isaac

  • Predrag Dubajic

    Hi Isaac,

    Can you make sure that the code Adam gave you is placed above /* That's all, stop editing! Happy blogging. */ line and that it has semicolon at the end, these are most common issues that could cause that Parse error.

    Also, could you tell us which PHP version is used on your site, and have you tried renaming your plugins folder via FTP to see if indeed plugin is causing this?

    Best regards,
    Predrag

  • Isaac

    Hi,

    Yes, the code was above the /* That's all, stop editing! Happy blogging. */ line, and included a semi colon, the parse error was from a different line, but goes away for some reason when the code is removed. I was using PHP 5.4, but upgraded to 5.6 to see if that would help, and it did not. I also renamed the plugin folder, and was still unable to access. I also disabled the caching plugin I was using two days ago. Could I provide ftp access to the site to have support take a look? This is for a client site, and I really need to get access.

    Thanks,
    Isaac

  • Predrag Dubajic

    Hi Isaac,

    You can send us your details using our contact form https://premium.wpmudev.org/contact/ and the template below:

    IMPORTANT: Make sure you select "I have a different question" for your topic so it doesn't go back to forums - this and the subject line ensure that it gets assigned to me.

    Subject: "Attn: Predrag Dubajic"
    - WordPress admin username
    - WordPress admin password
    - Login url
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant urls

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Isaac,

    Thanks for sending in those details, I have checked your installation but had no luck in getting your subsite to work.

    I tried switching the theme, removing caching from wp-config.php, reverting to default .htaccess rules and nothing gave any results.
    Creating new subsite with the same theme does however work so it's something specific to this subsite.

    Have you tried contacting your hosting provider so they can check server logs and that might tell us what's going on?

    Best regards,
    Predrag

  • Isaac

    I just tried using the define('WP_ALLOW_REPAIR', true); command and got the following error:

    The wp_sitemeta table is not okay. It is reporting the following error: 5 clients are using or haven't closed the table properly. WordPress will attempt to repair this table…
    Failed to repair the wp_sitemeta table. Error: 5 clients are using or haven't closed the table properly

    Any thoughts on how to fix that?

  • Isaac

    I was able to resolve my problem by repairing the wp_sitemeta table in the database. I then inserted the define('WP_ALLOW_REPAIR', true); command in my wp-config file and ran the database repair tool on wordpress by navigating to http://mysite.com/wp-admin/maint/repair.php and clicked the "repair and optimize" option. I then navigated to my plugin files via ftp, changed them to plugins-old . I was able to navigate back to the site. I changed them theme on the site, changed the plugin files back to "plugin". It looks like when I was updating a theme via ftp, the site defaulted to another theme that got deleted as far as I can tell.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.