I get a pair of errors in the apache error log

Hello,
I have found a pair of error messages in the error log, both from your plugin and it seems something about the multisite option. Could you please tell me how to fix it?

The messages:

"[Tue Jun 05 05:29:13 2012] [error] [client 66.249.66.67] PHP Fatal error: Class 'WP_Widget' not found in /var/www/wp-content/plugins/wpmu_dev_maps_plugin/lib/class_agm_maps_widget.php on line 6
[Tue Jun 05 08:25:51 2012] [error] [client 66.249.66.67] PHP Fatal error: Call to undefined function is_multisite() in /var/www/wp-content/plugins/wpmu_dev_maps_plugin/lib/forms/plugin_settings.php on line 7"

Thanks

  • aecnu

    Greetings 8tintin,

    Welcome to WPMU Dev!

    After doing a brief investigation into your reported issue I found that Google Bot (client 66.249.66.67) is indeed causing the error by trying to spider those files.

    These directories should be made inaccessible to search engines using the robots.txt file with the following settings:

    User-agent: *
    Disallow: /wp-content/cache/
    Disallow: /wp-content/themes/
    Disallow: /wp-content/plugins/
    Disallow: /wp-admin/
    Disallow: /wp-includes/
    Disallow: /wp-login.php
    Disallow: /wp-register.php
    Disallow: /images/
    Disallow: /imaging/

    Which tells all search engines not to spider the applicable folders. Customize to your needs.

    I have attached a pre-made file for your convenience and use and the file should be located in the root folder of your installation.

    Thank you for being a WPMU Dev Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.