I get an error from the plugin User Synchronization

I have everything on my site up-to-date, but the plugin User Synchronization give now an error:

Strict Standards: Redefining already defined constructor for class User_Sync in /customers/1/f/e/vanwelie.net/httpd.www/wp-content/plugins/user-sync/user-sync.php on line 47 Warning: set_time_limit(): Cannot set max execution time limit due to system policy in /customers/1/f/e/vanwelie.net/httpd.www/wp-content/plugins/user-sync/user-sync.php on line 75 Warning: Cannot modify header information - headers already sent by (output started at f????#?? :47) in /customers/1/f/e/vanwelie.net/httpd.www/wp-includes/pluggable.php on line 1196

How can I fixe it? Or you?

Best Regards,
Dennis

  • Dennis van Welie

    I have checked the wp-config.php and set the WP_DEBUG to "false". Now I get the next error in the Admin-area (translated with Google Translate from Dutch to English):

    The plugin generated 182 characters of unexpected output during activation. If you are noticing "headers already sent" messages, or problems arise with the RSS feeds or other problems, try this plugin then disable or delete them.

    On the front-page I get the next error:

    Warning: set_time_limit(): Cannot set max execution time limit due to system policy in /customers/1/f/e/vanwelie.net/httpd.www/wp-content/plugins/user-sync/user-sync.php on line 75 Warning: Cannot modify header information - headers already sent by (output started at /customers/1/f/e/vanwelie.net/httpd.www/wp-content/plugins/user-sync/user-sync.php:75) in /customers/1/f/e/vanwelie.net/httpd.www/wp-includes/pluggable.php on line 1196

    I have serveral times disable and delete the plugin, but the problem still stay.
    I hope you can help my out!

    Best regards,
    Dennis

  • Sajid

    Hi @Dennis

    Hope you are doing good today :slight_smile:

    Have you tried deactivating other plugins and theme ? Please try to deactivate other plugins and then check if the error is still there .

    Also try adding below code in wp-config.php file replacing define('WP_DEBUG', true );.

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors',0);

    Take care and have a nice weekend :slight_smile:

    Cheers, Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.