I get an error "Simplify Token not correctly generated"

I have had this plug-in installed and have ran the sandbox versions without any issues. I have just re-joined the community because the plug in stopped working. I get the error message "Simplify Token no Correctly Generated" I have contacted Simplify Commerce regarding this issue and they say that the plug in is not connecting to them to create the token. This brings me back here. I am a bit cranky over this as I am losing income as it sits broken. any assistance would be greatly appreciated.

  • Vaughan
    • Support/SLS MockingJay

    Hi @christopher,

    I know the developer has pushed some updates for simplify in the latest versions, but I see you are already using the latest release.

    I can't seem to find any other info regarding this error.

    Can you check in your error_log files in public_html & public_html/wp-admin

    See if there are any errors listed at all.

    In the mean time I'll ask the developer for some feedback on this, hopefully he should respond shortly.

    Hope this helps

  • Christopher
    • Design Lord, Child of Thor

    Vaughan,

    Thank you for the reply but I see nothing amiss. I am totally at a loss here, and as I mentioned hoped that it was an easy account issue with Simplify. However it is not. I really like this payment platform and hope someone has an answer for me. Please let me know if you find more information. seems to me the input is just not being logged therefor not requesting a token. but I'm not a tech person.

    regards
    Chris

  • Jonathan
    • The Bug Hunter

    Hiya @Christopher,

    It looks like there a couple of errors not related to MarketPress on your site.

    1. There a javascript file that can't be found - https://www.lunagrown.com/wp-content/uploads/wppa/temp/wppa.jstvlgaes792kruj8dn26js590.js?ver=4058

    2. Not sure what is outputing this, but a plugin or the theme you're using is outputting: document.body.style.webkitTouchCallout='none'; -- which is causing an error.

    Unfortunately, with javascript (which Simplify relies on to generate tokens) if there is an error ANYWHERE it will cause everything after that to error out.

  • Christopher
    • Design Lord, Child of Thor

    Hello Jonathan, and thank you for taking a look. I just turned off all plug ins (except for wpmu and a lock down one) I still get the same error. I have had issues with the wppa before... I don't know what the document body style is. either way I'm still getting the same feedback from the Simplify. can you tell me where you found the information you posted so I can follow up a little deeper? I can't thank you all enough for the assistance.

  • Jonathan
    • The Bug Hunter

    Hey @Christopher,

    I did find a bug in one of the simplify files. I've attached a patched version. Please extract the zip file and upload the enclosed file to wp-content/plugins/marketpress/marketpress-includes/plugins-gateway/simplify-files. You'll want to make sure you override the existing simplify_token.js file that is already on your server.

    Sorry about that. And thanks for being a member!

  • Christopher
    • Design Lord, Child of Thor

    Johnathan,
    Ahhhh... thank you! I'm not certain how to do anything other than up load and unzip the file, so i'll wait to talk to the guy that owns the server i'm on. I don't know how you guys do this all day and remember to eat. Thank you very much for this help and I hope if others come across this issue this can help them as well.

    Best Regards!
    Chris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.