I get http error when I upload large files on my multisite

My media upload quota is 64mb. When I upload files below 10mb I have no problem. However when I upload files larger than 10mb, but smaller the 64mb I get an error message when crunching. I upload my file via FTP using my network successfully, (I thought my network was the issue) but can't upload successfully using the media uploader. I contact my host but they said the problem is not on their side. I need help to fix this.

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hey there, Sefa!

    There are a few things we can check here.

    First off, let's check the upload quota you have set in your network settings. Go to your Network Admin dashboard, then Settings > Network Settings. At the bottom, there's a section for changing your upload quota.

    Next, if you've got Pro Sites installed, you can check to see if you've used an upload quota there by going to Pro Sites > Modules & Gateways > Upload Quota.

    You also need to check two files on your server, wp-config.php, and php.ini.

    If that still doesn't get it, let's double check your server settings by having you make a new file named phpinfo.php in a plain text editor with this content:

    <?php phpinfo(); ?>

    Upload this to the same folder WordPress is installed in, and then visit the page (yoursite.com/phpinfo.php) Scroll through the settings, checking for any limit that's set to 10mb.

    This should hit every spot where the upload limit can be changed. :slight_smile:

    Have a great Sunday, Sefa!

  • Sefa
    • Flash Drive

    Hi Michelle,

    Thank you for the support. I was off for the New Year celebrations that is why I did not reply your comment.

    Happy New Year!

    I checked my saver configuration, Prosite plugin quota, Network Admin dashboard quota and php.ini, they have no problem. However, my wp-config.php file has no quota set. Would that be the problem? How can I set that?

  • aristath
    • Recruit

    Hello there @Sefa and a happy new year to you too! :slight_smile:

    Could you please grant us access to your backend so that we may see exactly what is happening?
    To do so, from your dashboard go to WPMUDEV => Support => Support Access and click on the "Grant access" button.

    Please note that you must have the WPMU DEV Dashboard plugin installed on your site to complete the above process.

    Cheers,
    Ari.

  • aristath
    • Recruit

    Hello again @Sefa,

    I just logged-in on your dashboard and took a look at your settings.
    From your dashboard please go to Network-Admin => Settings => General.
    You'll see there a setting called "Site upload space".
    That is now set to 36MB (see attached screenshot).
    Could you please raise that to something like 999MB and test if that resolves your issue?

    Please advise,
    Ari.

  • Sefa
    • Flash Drive

    Hi,

    Thank you very much for your efforts. I did what you said that but it never worked.

    I have gone around the problem by uploading my large files using FTP unto my server. I used a plugin from WordPress.org called "Add from Server", and uploaded the files into my wordpress site from the server.

    Regards.

    Sefa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.