I get internal server error on the social theme

1. I cannot customise the social theme from theme options- for example I wanted to change the logo. The option header settings seemed inactive. I tried another option it throws an internal server error.

2. So I removed the theme and activated again. I get the internal server error as below.
not sure what's wrong. I activated the remote service on my site
--------

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

    aristath

    Hello there @Supriya, I hope you're well today!

    An internal server error is pretty generic and could mean anything!

    Could you please set WP_DEBUG to true in your wp-config.php file and try to replicate this again?
    This time you should be getting some errors on your screen, most notably a PHP Fatal Error.
    Please post the details of that error here so that we may figure out what goes on!

    Cheers,
    Ari.

    Supriya

    Hi, further to my report of problems with your Buddy social theme and membership plugin, I decided to install them on a local host environment and troubleshoot myself. Here are the problems:

    Buddy Social: The "member profile " shows some the following error:

    **********************
    Notice: rss.php is deprecated since version 3.0! Use wp-includes/class-simplepie.php instead. in C:wampwwwbizynetwp-includesfunctions.php on line 3258
    Call Stack
    # Time Memory Function Location
    1 0.0010 241640 {main}( ) ..index.php:0
    2 0.0010 244712 require( 'C:wampwwwbizynetwp-blog-header.php' ) ..index.php:17
    3 0.5300 44881904 require_once( 'C:wampwwwbizynetwp-includestemplate-loader.php' ) ..wp-blog-header.php:16
    4 0.5520 45076440 include( 'C:wampwwwbizynetwp-contentthemesbp-socialcommunity.php' ) ..template-loader.php:74
    5 0.7120 45218008 the_content( ) ..community.php:15
    6 0.7120 45218672 apply_filters( ) ..post-template.php:222
    7 0.7130 45221688 call_user_func_array:{C:wampwwwbizynetwp-includesplugin.php:214} ( ) ..plugin.php:214
    8 0.7130 45221768 bp_replace_the_content( ) ..plugin.php:214
    9 0.7130 45221984 apply_filters( ) ..bp-core-theme-compatibility.php:662
    10 0.7130 45223352 call_user_func_array:{C:wampwwwbizynetwp-includesplugin.php:214} ( ) ..plugin.php:214
    11 0.7130 45223416 BP_Members_Theme_Compat->single_dummy_content( ) ..plugin.php:214
    12 0.7130 45223656 bp_buffer_template_part( ) ..bp-members-screens.php:436
    13 0.7130 45240024 bp_get_template_part( ) ..bp-core-template-loader.php:237
    14 0.7130 45240664 bp_locate_template( ) ..bp-core-template-loader.php:47
    15 0.7140 45242528 load_template( ) ..bp-core-template-loader.php:110
    16 0.7150 45267072 require( 'C:wampwwwbizynetwp-contentpluginsbuddypressbp-templatesbp-legacybuddypressmemberssinglehome.php' ) ..template.php:503
    17 0.7230 45272992 bp_get_template_part( ) ..home.php:43
    18 0.7230 45273696 bp_locate_template( ) ..bp-core-template-loader.php:47
    19 0.7240 45275568 load_template( ) ..bp-core-template-loader.php:110
    20 0.7250 45294896 require( 'C:wampwwwbizynetwp-contentpluginsbuddypressbp-templatesbp-legacybuddypressmemberssingleprofile.php' ) ..template.php:503
    21 0.7250 45295208 do_action( ) ..profile.php:18
    22 0.7290 45297864 call_user_func_array:{C:wampwwwbizynetwp-includesplugin.php:505} ( ) ..plugin.php:505
    23 0.7290 45298440 output_blog_rss_content( ) ..plugin.php:505
    24 0.7310 45479792 require_once( 'C:wampwwwbizynetwp-includesrss.php' ) ..bp-component-functions.php:398
    25 0.7310 45480192 _deprecated_file( ) ..rss.php:19
    26 0.7310 45480648 trigger_error ( ) ..functions.php:3258
    ***************************************

    I'll submit the problem with the Membership plugin in another request

    Supriya

    Thanks so much Ari,

    Not sure what was the problem: I had the following message when I tried to browse to the site:

    Notice: like_escape is deprecated since version 4.0! Use wpdb::esc_like() instead. in /hermes/bosnaweb08a/b2425/ipg.digiadca/bizynet/wp-includes/functions.php on line 3201 Notice: like_escape is deprecated since version 4.0! Use wpdb::esc_like() instead. in /hermes/bosnaweb08a/b2425/ipg.digiadca/bizynet/wp-includes/functions.php on line 3201 Warning: Cannot modify header information - headers already sent by (output started at /hermes/bosnaweb08a/b2425/ipg.digiadca/bizynet/wp-includes/functions.php:3201) in /hermes/bosnaweb08a/b2425/ipg.digiadca/bizynet/wp-includes/pluggable.php on line 1173

    But I somehow managed to get into the wp-admin and saw a couple of updates in WMMU. When I did those things were fine!

    I hope I can finish my work now. Thanks again for your help

    aristath

    Hello again @Supriya,

    The issue must have been the "Warning: Cannot modify header information - headers already sent by" message.
    Probably one of the updates you performed fixed that...
    I'm glad you managed to fix this!
    I'll go ahead and mark this as resolved for now.
    If however you need any further assistance here don't hesitate to reopen this and post an update on your current status.

    Take care!
    Ari.