I get the following error when trying to login

I get the following error when trying to login to the dashboard:

Your server had a problem connecting to WPMU DEV: "SSLRead() return error -9806". Please try again.

If this problem continues, please contact your host with this error message and ask:

"Is php on my server properly configured to be able to contact https://premium.wpmudev.org/api/dashboard/v1/ with a POST HTTP request via fsockopen or CURL?"

NOTE: CURL is installed and functioning on my server. Below is the output from a php_info call. I am using a self signed SSL certificate on a private network.

ALSO: I turned off the firewall on my server. I get the same error. Since I turned off the firewall, I do not think this is the issue.

ALSO: There are no other plugins installed except "Akismet" and "Hello Dolly".

ALSO, since the dashboard does not work, I thought I would try to download some plugins and manually install them. However, when I go to the plugins I only have the option to INSTALL. There is no option to say "No thanks, just download directly" and install manually. NOTE: I am registered with the 14 day trial period. Needless to say, the trial is not going so well.

PHP_INFO Output:
curl

cURL support enabled
cURL Information 7.37.1
Age 3
Features
AsynchDNS Yes
CharConv No
Debug No
GSS-Negotiate Yes
IDN No
IPv6 Yes
krb4 No
Largefile Yes
libz Yes
NTLM Yes
NTLMWB Yes
SPNEGO No
SSL Yes
SSPI No
TLS-SRP No
Protocols dict, file, ftp, ftps, gopher, http, https, imap, imaps, ldap, ldaps, pop3, pop3s, rtsp, smtp, smtps, telnet, tftp
Host x86_64-apple-darwin14.0
SSL Version SecureTransport
ZLib Version 1.2.5

    Milan

    Hello Chris,

    I hope you are having a good day and thanks for asking us.

    Dear member this error occurs sometimes on some serves, but this can be easily fix by your hosting provider if they look at SSL and Curl settings on your end. You can describe your this issue to them to help them get insights of what's going on.

    But before you contact your hosting provider I suggest you try out this line in your wp-config.php file which resides in your site's root folder.

    define( 'WPMUDEV_CUSTOM_API_SERVER', 'https://premium.wpmudev.org/' );

    Let me know how it goes for you.

    Cheers,
    Milan

    Chris

    Hi Milan, I do not think the non-secure method of logging into WPMU DEV is the best answer.
    I did try the non-secure method and it did work, but I cannot use that long term.
    In my initial post, I asked about being able to install plugins manually. Can you please answer that portion of my question? HOW do I install plugins/themes manually without using the dashboard?

    Additionally, SSL and CURL are working on my server. I am the sys admin for my server and will do the configuration myself. Please see the output from CURL on the command line. As you can see it is working and I get output. I need you to provide particular configuration settings you expect configured on my server for CURL + SSL.

    Thanks,
    Chris

    OUTPUT FROM CURL ON COMMAND LINE:

    sh-3.2# curl https://premium.wpmudev.org/api/dashboard/v1/
    {"namespace":"dashboard\/v1","routes":{"\/dashboard\/v1":{"namespace":"dashboard\/v1","methods":["GET"],"endpoints":[{"methods":["GET"],"args":{"namespace":{"required":false,"default":"dashboard\/v1"},"context":{"required":false,"default":"view"}}}],"_links":{"self":"https:\/\/premium.wpmudev.org\/api\/dashboard\/v1"}},"\/dashboard\/v1\/updates":{"namespace":"dashboard\/v1","methods":["POST"],"endpoints":[{"methods":["POST"],"args":{"api_key":{"required":false},"blog_count":{"required":true},"wp_version":{"required":true},"domain":{"required":true,"description":"The network_site_url() of the WP installation."},"home_url":{"required":false,"description":"The network_home_url() of the WP installation."},"admin_url":{"required":true,"description":"The network_admin_url() of the WP installation."},"projects":{"required":true}}}],"_links":{"self":"https:\/\/premium.wpmudev.org\/api\/dashboard\/v1\/updates"}},"\/dashboard\/v1\/user-info\/(?P<api_key>[\\w-]+)":{"namespace":"dashboard\/v1","methods":["GET"],"endpoints":[{"methods":["GET"],"args":{"api_key":{"required":true}}}]},"\/dashboard\/v1\/changelog\/(?P<project_id>[\\d]+)":{"namespace":"dashboard\/v1","methods":["GET"],"endpoints":[{"methods":["GET"],"args":{"project_id":{"required":true}}}]},"\/dashboard\/v1\/authenticate":{"namespace":"dashboard\/v1","methods":["POST"],"endpoints":[{"methods":["POST"],"args":{"username":{"required":true},"password":{"required":true},"redirect_url":{"required":true},"domain":{"required":false,"description":"The network_admin_url() of the WP installation."}}}],"_links":{"self":"https:\/\/premium.wpmudev.org\/api\/dashboard\/v1\/authenticate"}},"\/dashboard\/v1\/usage\/(?P<project_id>[\\d]+)":{"namespace":"dashboard\/v1","methods":["GET"],"endpoints":[{"methods":["GET"],"args":{"project_id":{"required":true}}}]},"\/dashboard\/v1\/download\/(?P<project_id>[\\d]+)\/(?P<api_key>[\\w-]+)":{"namespace":"dashboard\/v1","methods":["GET"],"endpoints":[{"methods":["GET"],"args":{"project_id":{"required":true},"api_key":{"required":true}}}]},"\/dashboard\/v1\/install\/(?P<project_id>[\\d]+)\/(?P<api_key>[\\w-]+)":{"namespace":"dashboard\/v1","methods":["GET"],"endpoints":[{"methods":["GET"],"args":{"project_id":{"required":true},"api_key":{"required":true}}}]},"\/dashboard\/v1\/download-dashboard":{"namespace":"dashboard\/v1","methods":["GET"],"endpoints":[{"methods":["GET"],"args":[]}],"_links":{"self":"https:\/\/premium.wpmudev.org\/api\/dashboard\/v1\/download-dashboard"}},"\/dashboard\/v1\/grant-access":{"namespace":"dashboard\/v1","methods":["POST"],"endpoints":[{"methods":["POST"],"args":{"api_key":{"required":true},"domain":{"required":true},"auth_key":{"required":true},"auth_url":{"required":true},"auth_expire":{"required":true}}}],"_links":{"self":"https:\/\/premium.wpmudev.org\/api\/dashboard\/v1\/grant-access"}},"\/dashboard\/v1\/revoke-access":{"namespace":"dashboard\/v1","methods":["POST"],"endpoints":[{"methods":["POST"],"args":{"api_key":{"required":true},"domain":{"required":true}}}],"_links":{"self":"https:\/\/premium.wpmudev.org\/api\/dashboard\/v1\/revoke-access"}},"\/dashboard\/v1\/test":{"namespace":"dashboard\/v1","methods":["POST","GET","PUT","PATCH","DELETE","COPY","HEAD"],"endpoints":[{"methods":["POST","GET","PUT","PATCH","DELETE","COPY","HEAD"],"args":[]}],"_links":{"self":"https:\/\/premium.wpmudev.org\/api\/dashboard\/v1\/test"}}},"_links":{"up":[{"href":"https:\/\/premium.wpmudev.org\/api\/"}]}}sh-3.2#

    Adam Czajczyk

    Hello Chris,

    I hope you're well today!

    I think Milan may have focused on the SSL connection issue and missed the "manual install" part. I apologize for that.

    On plugin's/theme's description pages there's always a download link next to "Install" button that's available when you're logged in into your WPMU DEV account. However, the Trial Subscription is an exception here and during that period you're entitled to install plugins/themes via WPMU DEV Dashboard plugin only. When you decide to extend your membership to a full (meaning paid) subscription the download link will automatically appear for your there.

    That said, I think we need to solve that SSL issue then. Thanks for sharing curl output. Could you also tell me please what web server and PHP version are you using?

    Best regards,
    Adam

    Chris

    Thanks Adam,

    I appreciate your response. My version info is as follows:
    sh-3.2# httpd -v
    Server version: Apache/2.4.10 (Unix)
    Server built: Jan 8 2015 20:48:33
    sh-3.2# php -v
    PHP 5.5.20 (cli) (built: Feb 25 2015 23:30:53)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies

    The httpd error log shows the following:
    [Tue Mar 29 20:27:56.860964 2016] [:error] [pid 17519] [client 192.168.x.x:60252] [WPMUDEV API Error] 4.0.9 | SSLRead() return error -9806 ((unknown URL) [500]) , referer: http://mydomain.com/wp-admin/network/admin.php?page=wpmudev

    I think the problem is the dashboard does not seem to work with SSL when the client is on a private network without a DNS resolving domain.

    Aaron

    Hi there, had a talk with our sysadmins. Are you on a Mac server perhaps? This error is usually caused by php being compiled to use an out of date ssl provider from Apple instead of OpenSSL. So php curl tried to connect over the now insecure SSLv3 which we've disabled because of POODLE.
    https://wordpress.org/support/topic/error-executing-wp_remote_post-sslread-return-error-9806
    http://stackoverflow.com/questions/26461966/osx-10-10-curl-post-to-https-url-gives-sslread-error
    You should be able to confirm and fix that using the instructions in the second link.

    Sorry again for your troubles as a new member! Rest assured these kind of issues are very rare, hopefully it's smooth sailing for you from now on!