I get this debug error notice: "Strict Standards:

Hello,

I get this debug error notice:
"Strict Standards: Declaration of BP_Group_Calendar_Extension::display() should be compatible with BP_Group_Extension::display($group_id = NULL) in /nas/wp/www/cluster-41320/spiritberlin/wp-content/plugins/bp-group-calendar/groupcalendar/bp-group-calendar.php on line 102"

Do you know how i can fix this?

Best,
Jacob

  • Adam Czajczyk
    • Support Gorilla

    Hello Jacob,

    I hope you're well today and thank you for your question!

    I tried to replicate this on my own setup but with no luck. I've asked one of my colleagues to look into the plugins code and the suggestion would be to edit the

    /wp-content/plugins/bp-group-calendar/groupcalendar/bp-group-calendar.php file around line 102 and replace this line:

    function display() {

    with

    function display($group_id = null) {

    Would you please give it a try and let me know if it helped?

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Jacob!

    I'm glad to hear that it helped!

    The change will, unfortunately, be overridden by the next plugin up date but I have already marked this as a bug and forwarded to the developers so hopefully they'll just include the fix into the next release. I think though it would be better if you wrote this down for future reference, just in case :slight_smile:

    Cheers,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.