I get this error when trying to create new sites in my MU

I get this error when trying to create new sites in my MU install. I have another install thats pretty identical so I cannot figure out the problem. Any help would rock as to where I should be looking and what I should do. I contacted hostgator and they are being especially slow to respond. Thanks for any help with this one.

Warning: fopen(/home2/pulciano/public_html/showbizhill.com/wp-content/plugins/EMPTY): failed to open stream: No such file or directory in /home2/pulciano/public_html/showbizhill.com/wp-includes/functions.php on line 4004

Warning: fread() expects parameter 1 to be resource, boolean given in /home2/pulciano/public_html/showbizhill.com/wp-includes/functions.php on line 4007

Warning: fclose() expects parameter 1 to be resource, boolean given in /home2/pulciano/public_html/showbizhill.com/wp-includes/functions.php on line 4010

Warning: Cannot modify header information – headers already sent by (output started at /home2/pulciano/public_html/showbizhill.com/wp-includes/functions.php:4004) in /home2/pulciano/public_html/showbizhill.com/wp-includes/pluggable.php on line 1179

  • Vinod Dalvi
    • WP Unicorn

    Hi @michael,

    Sorry to hear of the problem you are having.

    This is a simple PHP warning and most of the time it doesn’t affect functionality of site so it is nothing to worry about!

    Do you have WP_DEBUG set to true in your wp-config.php file?

    If you do then please set it to false.

    This will hide the warning messages and you will be able to use your site normally.

    Do you have EMPTY directory in the plugins directory if yes then try temporary removing it?

    /home2/pulciano/public_html/showbizhill.com/wp-content/plugins/EMPTY

    If it doesn’t help and if you are getting this warning messages wven when the wp debug is set to false then can you please try enabling WP_DEBUG mode? To do this, just go to wp-config.php include this:

    define('WP_DEBUG',true);

    You might already have a line for WP_DEBUG, so just make sure it’s set to true.

    For information on this, checkout this wpmu.org article.

    Let me know what more errors if any you are getting when you face this issue so that i can troubleshoot it.

    Kind Regards,

    Vinod Dalvi

  • Michael
    • Site Builder, Child of Zeus

    Ok, so there is not an EMPTY file in the plugin folder. I have some plugin specific errors. I deactivated then deleted the plugins and those errors left.

    I did not have a WP debug in the wp confing file. I added it and it did nothing.

    I changed it form true to false and back again and I still get the same errors.

  • Vinod Dalvi
    • WP Unicorn

    Hi @michael,

    Thank you for your reply.

    Ok, so there is not an EMPTY file in the plugin folder.

    I didn’t talk about the file but the directory which i saw in the following warning message that you have shared.

    Warning: fopen(/home2/pulciano/public_html/showbizhill.com/wp-content/plugins/EMPTY): failed to open stream: No such file or directory in /home2/pulciano/public_html/showbizhill.com/wp-includes/functions.php on line 4004

    I have some plugin specific errors. I deactivated then deleted the plugins and those errors left.

    Are there still any warning messages that are getting displayed when creating new sites?

    If yes then would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking “Grant Access” button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Regards,

    Vinod Dalvi

  • Jack Kitterhing
    • Code Norris

    Hi there @michael,

    Hope you’re well today and thanks for your question!

    I’ve been looking into this and the site I created doesn’t work either, I get a “could not connect to server” after site creation, do you have a Wildcard A record set at your hosting?

    If you could check and confirm please :slight_smile: It should be *.domain.com

    Thank you!

    Kind Regards

    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.