image default link type problem

I got a dilemma here... I tried to set the image_default_link_type to none but when i use the plugin where it calls the media drawer to set a category image, because the link is set to none, even i click "use this image" it won't work, I must click the "file" button in the link to mkae it work, but I am doing a multisite , users in the network will not know how to deal with this issue, either I change the image_default_link_type back to file so that people can set the ctageory image, but then they will again have to click "none" everytime in the link section in the media drawer to avoid the file being linked to image... are there better way to do it?

  • Jack Kitterhing

    Hi there @bueport

    I hope you are well today, you've lost me a little on this one.

    Are you using any other media plugins? This is the default WordPress media uploader? You want link type to none as a default.

    because the link is set to none, even i click "use this image" it won't work, I must click the "file" button in the link to mkae it work,

    But you don't want it to link to anything do you, which use this image? A featured image? Something else?

    Please advise.

    Thank you for being a WPMU DEV member!

    Kind Regards
    Jack.

  • bueport

    I do want to "use this image" , , if I already set image_default_link_type = none in the theme function.php, then in some plugins like the easy blogging in wpmu, when you set the icon for the menu, because the link leave blank, even I click "use this image" the link will never fill up so it won't work, only if I click "file" in the link section before I click"use this image", eventually it works, but I don't want that, I want even I don't have any link set in the link section, whever I click "use this image" , the link fill up the plugin's image link

    I want to keep the link section empty because people adding media into their post will not want to link to a file.

  • bueport

    here attached the easyblogging plugin icon setting problem if I set the image_default_link_type = none, even I click "use this image" it won't have any effect because the link is not filled, but many other plugins that I want users to use like "category image" they also use "use this image" method, so I don't know what to do... either set the link to file they users got trouble posting image...

  • Jack Kitterhing

    Hi there @bueport

    I hope that you are well today, sorry for the extreme delay with my response, I apologize about that, I missed your previous reply's.

    I'm afraid that this seems like a default WordPress way to do this, As I've been taking a look at this on my own installs, would you mind using a different uploader?

    Thank you! Again sorry for the delay on this, I'm happy to assist :slight_smile:

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.