I got a problem commenting on wpmu.org

I tried commenting on this thread via Facebook: https://premium.wpmudev.org/blog/manage-multiple-wordpress-sites-from-one-location-with-this-free-tool/ and after clicking "comment" a few seconds later I am back on that page and my comment is nowhere to be seen.

Could someone please check that out?

And just for completeness, here is the comment I was trying to publish, maybe someone can help over here:

I wanted to give infinitewp a try but on the prerequisites site I get this warning:

ASYNC CALL SUPPORT
PHP should be able to access files in the same server through a full url

And I got no useful reply on their forum or via email. Its a self managed server and all I need to know is what is missing, a php setting or module?

  • Shawn
    • The Crimson Coder

    I wish I could answer the question for you, but I just started using InfiniteWP myself.

    So far, it's far more than I imagined it would be. Setup was very simple (I used a dedicated subdomain unattached to any of the other sites I operate), and it worked extremely well.

    Totally guessing here - any chance the URL you're using isn't "real"? Such as example.com, or something that won't be navigable/hittable from your WP sites on other servers? If the URL doesn't really exist, it would be impossible for the WP sites to ping it with update notifications and log data.

  • Ovidiu
    • Code Wrangler

    Sorry for the delay but I never got any notifications about answers on this thread :slight_frown:

    Well, the problem is partially solved: I had to create a Page Rule within Cloudflare to excempt the folder where InfiniteWP resides. Next I had to create an exception (jsut as a precaution) to excempt it from mod_Pagespeed running on my server.

    Now I am stuck with random timeouts every now and then :slight_frown:
    Might have to move it to another domain.

    Btw. it was even picking up on my multisite installation's .htaccess file I had to devise a workaround with the InfiniteWP author to get past that (multisite is here: domain.tld InfiniteWP is here: domain.tld/InfiniteWP/ )

    And yes, safe mode is enabled but on another domain on the same server with the same config the problem doesn'T happen so it must be Cloudflare related :slight_frown:

  • Shawn
    • The Crimson Coder

    I wouldn't trust cloudflare with this - it would be far better to just use a randomly named subdomain specificaly dedicated to InfiniteWP, as that would ensure that it couldn't be accidentally discovered (and potentially exploited) by an evil bot and would be capable of running completely different settings than the restrictions imposed on the WP sites. InfiniteWP does NOT require the WP installation on the same host or even the same server as any of the WP clients - it can (and IMO should) be a completely standalone install.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.