I got an error 500 running snapshot plugin

During a backup process using Snapshot WP plugin, I received the following error message:
500 Server Error
A misconfiguration on the server caused a hiccup. Check the server logs, fix the problem, then try again.
________________________________________
URL: http://cooplexityinstitute.biz/wp-admin/admin-ajax.php

  • Bojan Radonic
    • Head of Support

    Hey there @Ricardo, hope you're well today!

    Could you please check your server's error logs? That will give us more information on what's going on behind the scenes. 500 errors get logged so you shouldn't have much trouble finding them.

    Additionally most likely you are running out of memory so you'd want to take a look at the memory settings in your wp-config.php. Please check http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP If you are running BuddyPress and other large plugins you really want to up this to 256M.

    Looking forward for your response.

    Best regards,
    Bojan

  • Ricardo
    • Design Lord, Child of Thor

    Hi Bojan,
    This is a picture of what I got.
    I granted you access to the site.
    It always stops at plugins.
    I have also asked Bluehost and told me there is nothing on the logs so they have scaled the matter.
    Let me know.
    Thanks
    Ricardo

  • Bojan Radonic
    • Head of Support

    Hey again @Ricardo,

    Sorry to hear that didn't help :slight_frown:

    Could you please try doing a smaller snapshot without the plugins to see if it completes and if it does then I would say it's a timeout problem and you have to increase the timeout. Please try increasing max_execution_time as well.

    Please let me know if this helps :slight_smile:

    Cheers,
    Bojan

  • Ricardo
    • Design Lord, Child of Thor

    Hi,
    Any of both options worked.
    1. Add this line to your wp-config.php file:
    ini_set('max_execution_time', 300);
    I tried first to modify the config file resulting in a blank page:
    2. Edit your php.ini file and change the value of max_execution_time there.
    I changed the following values without positive results:
    ;;;;;;;;;;;;;;;;;;;
    ; Resource Limits ;
    ;;;;;;;;;;;;;;;;;;;

    ; Maximum execution time of each script, in seconds
    ; http://php.net/max-execution-time
    ; Note: This directive is hardcoded to 0 for the CLI SAPI
    max_execution_time = 300

    ; Maximum amount of memory a script may consume (128MB)
    ; http://php.net/memory-limit
    memory_limit = 256M

    I also asked the Hosting support about the problem but cannot understand the answer:
    I have verified the issue. to resolve this issue please try uploading the core files of wordpress to the path '/home1/cooplexi/public_html/cooplexitybiz/' so that the issue will be resolved.

    Does it have sense to you?
    Best regards
    Ricardo

  • Predrag Dubajic
    • Support

    Hi @Ricardo,

    Hope you're well.

    I have verified the issue. to resolve this issue please try uploading the core files of wordpress to the path '/home1/cooplexi/public_html/cooplexitybiz/' so that the issue will be resolved.

    This basically mean to reinstall your WordPress since all your WP files should be in that folder.

    If you are going to do this I suggest making a backup first, and either replace all files and then restore your wp-confing.php file and wp-content folders or upload WP files without those two.

    It would also help if they can give you some more details on why you should reinstall WordPress.

    Best regards,
    Predrag

  • Ricardo
    • Design Lord, Child of Thor

    Hi Pedrag,
    This has nonsense at all to me. They should be mistaken.
    If I check the files all are there. Even more, I did not install WP using the automatic Mojo method. I did it manually. It means all WP files are in the right place. I am sure.
    This is a complex multisite working fine with people interacting without any problem. I deeply doubt Bluehost really took a serious look at it. I have already got the advice to reinstall other WP installations or a backup, and then I found a simple or silly cause.
    My guess is that the problem belongs to WP, the Snapshot plugin or to any kind of compatibility as they did not see anything at the logs.
    Do you think it could be by a different cause?
    Regards
    Ricardo

  • Michelle Shull
    • DEV MAN’s Apprentice

    Hi, Ricardo!

    Since Snapshot always fails while copying the plugins, I bet there's a glitch in one of the plugins that's being copied, which is causing whatever failure that leads to Snapshot locking up. Narrowing down which plugin that is will be tricky, as snapshot will also backup inactive plugins, so we can't just deactivate half and try again. What we can do is create some temporary exclusions for some plugin folders.

    Go to Snapshot > Settings, and scroll down until you see Global File Exclusions. It's highlighted yellow in my screenshot below. In the box underneath, enter the URLs for your five or so most robust plugins' folders, like so: yoursite.com/wp-content/plugins/plugin_name/.

    Now attempt to run a Snapshot. If it works, it's one of the five or so plugins you excluded. Delete one plugin from your exclusion list, then try again, until you figure out the guilty one.

    If Snapshot still fails, delete all the URLs from the excluded list, and replace with five different plugins' folders.

    I'm willing to bet there's one plugin here that's causing all your issues, unfortunately, tracking it down is going to take a little trial and error.

    One other option, have you tried switching compression methods, the part highlighted in blue in my screenshot? If you're currently using PCIzip, try ZipArchive.

    Thanks Ricardo!

  • Bojan Radonic
    • Head of Support

    Hey there @Ricardo,

    Glad you managed to find that and get everything to work. Since this is a premium plugin I'd like you to send us your FTP details so we can test this out and forward to our developers through our contact form https://premium.wpmudev.org/contact/ using this template:

    Subject: "Attn: Bojan"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    Best regards,
    Bojan

  • Bojan Radonic
    • Head of Support

    Hey there @Ricardo,

    I've been trying to replicate this on my end by using plugins you mentioned but the backup went through just fine. There were no errors in the log so I guess this could be related to some specific settings in one those two plugins or still related to your server specifically.

    I'll let you know if I find anything else.

    Best regards,
    Bojan

  • Ricardo
    • Design Lord, Child of Thor

    Hi Bojan,
    These two plugins are part of a bundle offer included in my theme.
    To update them I have to delete them first and install again each time the theme updates.
    I do not know if this could be a clue, but I guess the behaviour of a plugin is probably different in each case.
    Regards
    Ricardo

  • Michael Bissett
    • Recruit

    Hey @Ricardo,

    I've been trying to do some investigating of my own here, but this is looking like a tricky one. :disappointed:

    Oddly enough though, I'm still seeing a 500 Internal Server error come up on your site when I try performing a test snapshot, even with your Global Exclusions in place. I've called in my colleague @Jack Kitterhing about this, so that he can provide his thoughts on the situation. :slight_smile:

    Kind Regards,
    Michael

  • Jack Kitterhing
    • Code Norris

    Hi there @Ricardo,

    Hope you're well today, I've been doing some testing both on your site and my own and wasn't able to replicate this on my own even using the same two plugins we believe are causing the issues on yours.

    I've updated Snapshot on your site as well, can you let me know if you have any form of server side caching (including object cache), if you are on shared hosting, you may need to check this with your host.

    Thanks!

    Kind Regards
    Jack.

  • Ricardo
    • Design Lord, Child of Thor

    Thanks Michael,
    Hi Jack,
    I asked to Bluehost and we do not have any form of server side caching (including object cache). The developer told me there is not such caching unless I do it which is not the case.
    Best
    Ricardo

  • Michael Bissett
    • Recruit

    Hey @Ricardo,

    After doing some further testing on your site, I was able to get a plugin snapshot (which included the plugins you had previously set exclusions for) by setting "Set Compression Option" to "ZipArchive" & increasing the memory to 512M.

    Could you confirm the same on your end please? :slight_smile:

    Kind Regards,
    Michael

    P.S. The snapshot I had tested with was the "WPMU DEV Test Snapshot".

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.