i got this msg from admin view : Warning: session_start()

i got this msg from admin view :

Warning: session_start() [function.session-start]: open(/tmp/sess_3c1c6b607b8d3518a4500c28339b539e, O_RDWR) failed: Permission denied (13) in /home/ppa1m/public_html/wp-content/plugins/wpmu_dev_maps_plugin/inc/external/wpmu-lib/inc/class-thelib-base.php on line 68

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/ppa1m/public_html/wp-content/plugins/wpmu_dev_maps_plugin/inc/external/wpmu-lib/inc/class-thelib-base.php:68) in /home/ppa1m/public_html/wp-content/plugins/wpmu_dev_maps_plugin/inc/external/wpmu-lib/inc/class-thelib-base.php on line 68

Warning: Cannot modify header information - headers already sent by (output started at /home/ppa1m/public_html/wp-content/plugins/wpmu_dev_maps_plugin/inc/external/wpmu-lib/inc/class-thelib-base.php:68) in /home/ppa1m/public_html/wp-includes/option.php on line 747

Warning: Cannot modify header information - headers already sent by (output started at /home/ppa1m/public_html/wp-content/plugins/wpmu_dev_maps_plugin/inc/external/wpmu-lib/inc/class-thelib-base.php:68) in /home/ppa1m/public_html/wp-includes/option.php on line 748

  • Ash

    Hello @Rocket Web

    Welcome to WPMU community!

    I hope you are well today and thanks for asking the question.

    Would you please make sure your host that your tmp folder is writeable and you have access to that folder.

    If you are host, you may need to add this in your php.ini:

    session.save_path - /tmp

    And then give the permission 0777 for that folder.
    Restart apache.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.

    Cheers
    Ash

  • Michael Bissett

    Hey @Rocket Web, hope you're doing well today! :slight_smile:

    In this case, given the first part of this error:

    Warning: session_start() [function.session-start]: open(/tmp/sess_3c1c6b607b8d3518a4500c28339b539e, O_RDWR) failed: Permission denied (13) in /home/ppa1m/public_html/wp-content/plugins/wpmu_dev_maps_plugin/inc/external/wpmu-lib/inc/class-thelib-base.php on line 68

    We've run into a read/write permissions issue here with the /tmp/ directory, it's not allowing our Google Maps plugin to save temporary information there.

    This is something that you're going to want to get in touch with your host about, as this sort of configuration would be in their hands. Once resolved, you should see these errors go away. :slight_smile:

    Hope this helps!

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.