I have a client with the following needs: On Monday

I have a client with the following needs:
On Monday and Wednesday she is in Location A with certain hours
On Sunday she is in Location B with certain other hours.

I looked through other help threads in the Community and I followed the advice to create additional "dummy" service providers, and then to set a service to each service provider and a location to each service, and then the hours working according to each service. Thus location + days / hours are linked.

Thing is, it's not working on the site.

Please see: http://www.irgwebsites.com/rifka/book-an-appointment/

You'll see that if you select a location from the drop down, for instance "Skype / Phone" you will see all of the available dates altogether that are programmed in, which is everything on Sunday, Tuesday and Wednesday. What should show up is ONLY Wednesday from 8:30-10pm.

Other features seem to work.

Please advise.

  • Michael Bissett

    Hey @ilanaguttman, thanks for your patience here! :slight_smile:

    After having a look at your setup, I was wondering if perhaps the way I've set it up on this page might be more suitable for now:

    http://www.irgwebsites.com/rifka/wpmu-dev-test-page/

    I just used the [app_services] shortcode there in place of the [app_required_service_locations]; I didn't add the "autorefresh" parameter though, since it would prevent users from selecting the first option, like in your other form.

    How would this work for you? Or is there more to using the locations add-on here that I'm not aware of?

    Please advise,
    Michael

    P.S. There's more to my choosing the [app_services] shortcode, but thought it best to elaborate in an added section:

    There's another side affect to using "autorefresh" inside the [app_required_service_locations] shortcode with this sort of setup... it also keeps users from selecting the service properly.

    You'll notice that if you leave off the "autorefresh" parameter for the [app_required_service_locations] shortcode, the workflow on your site is like this:

    Click button to select location -> Click button to select the service attached to that location -> Choose available timeslot

    (you can see this take affect if you're using the Skype/Phone location on your site for this)

    The problem is that when autorefresh is set to "1", you'll be able to select a location... but you can't proceed with the rest of the workflow that I specified (thus, you're not seeing the right hours).

  • ilanaguttman

    Hi @Ashok
    Sorry for the delayed response. As I mentioned earlier I was away for a few days on a trip that I planned weeks ago. Back to work now!

    My client uses Google Calendar for all sorts of appointments, in addition to booking appointments via the website. A separate google calendar was created for the purpose of booking appointments via the website, as the plugin instructions say. However, if something comes up on another calendar, like let's say her personal calendar, with a doctor's appointment, at a time that she is usually free to work, it's not showing times as busy. The times are only booked as busy if they are booked via this website.

    For example she has appointments on Jan 4th 5th and 7th, but the only ones showing are times booked from this plugin.

    The plugin says that it can sync in both directions. How can we get this to work?

    I can understand that if an appointment made outside of the associated calendar is made, the associated calendar and the plugin can't read it. But how is this supposed to work, practically speaking?

    I shouldn't have to manually import anything if my settings are A+ <-> GCal. The plugin says that setting works in both directions. That said, even when manually importing data and manually exporting, I still have this problem.

  • ilanaguttman

    Additionally, it doesn't seem to always be working by adding new appointments made through the site to my GCal.

    If you look at the attached screen grabs, you will see that an appointment was registered in the system for January 4 at 10am and I received the confirmation email, and it is listed in the appointments in the plugin. But if I go to the Google Calendar, it does not show up.

  • Patrick

    Hi @ilanaguttman

    I hope you had a great vacation!

    Would you please re-enable support access from your WPMU DEV Dashboard so we can pop into your site to help you get this set up the way you want it? It would be a good idea to keep it enabled until the issue is resolved. :slight_smile:

    Also, have you double-checked that the Gcal key file has been uploaded to the right folder on your site, and that the filename has been entered in the plugin settings without the p12 extension?

    Finally, it would really help a lot if you could write up a simple chart illustrating the days, times, locations & service providers for each of your services. That way, we could help you get this set up lickety-split!

    Thanks!

  • ilanaguttman

    Hi @Patrick,

    1) WPMU Dev is reenabled. I forgot about the expiration last time and it took a lot longer than I expected to get a response. Is it possible to get an email warning when it's about to expire? Or I need to keep remembering to check it?

    2) I double-checked that the filename entered into the plugin settings is without the p12 extension and matches the filename that was uploaded to the correct place in the site files appointments > includes>gcal>key

    3) Please see the attached chart

    Thank you!

  • Ash

    Hello @ilanaguttman

    I hope you are well today.

    1) WPMU Dev is reenabled. I forgot about the expiration last time and it took a lot longer than I expected to get a response. Is it possible to get an email warning when it's about to expire? Or I need to keep remembering to check it?

    You need to keep remembering to check it.

    3) Please see the attached chart

    The chart is not attached. Would you please try again?

    Looks like there may be a problem with that extension, so I'm uploading again

    Is it going fine after re-uploading?

    If I need to cancel an appointment that is synced with Google Calendar, can I cancel from Google Calendar, or must I cancel from the Appointments list in WordPress?

    You must cancel from Appointments list. Deleting from google cal won't delete from the appointment list.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.

    Cheers
    Ash

  • ilanaguttman

    Hi - I appreciate your response, but it doesn't sound like you've addressed any of the issues.
    There is a problem uploading that requested chart for some reason. Here is a link you can view it at: https://www.dropbox.com/s/6krbi57fupnf4at/appointments%20schedule.xlsx?dl=0

    Again, this is a response to @Patrick:

    Would you please re-enable support access from your WPMU DEV Dashboard so we can pop into your site to help you get this set up the way you want it? It would be a good idea to keep it enabled until the issue is resolved. :slight_smile:

    DONE (yet again)

    Also, have you double-checked that the Gcal key file has been uploaded to the right folder on your site, and that the filename has been entered in the plugin settings without the p12 extension?

    YES

    Finally, it would really help a lot if you could write up a simple chart illustrating the days, times, locations & service providers for each of your services. That way, we could help you get this set up lickety-split!

    see link to file in dropbox above

    Please take another look.

    Thank you

  • Ash

    Hello @ilanaguttman

    I hope you are well today.

    Please check now. There is only problem with the time settings. According to time settings, for Phone/Skype service it can't be started from 8.30 pm, it will start from 9.00 pm. To show 8.30pm instead of 9.30pm to the users, please use the following code:

    add_filter( 'wp_head', 'app_ccs_cb' );
    function app_ccs_cb() {
    	?>
    	<script type="text/javascript">
    	jQuery(function($) {
    		$(".app_timetable_cell.free").each(function() {
    			var h = $(this).html(),
    			    t = h.replace( '9:00 pm', '8:30 pm' );
    			$(this).html(t);
    		});
    	});
    	</script>
    	<?php
    }

    You can add those codes in your functions.php in the theme, if you think your theme won’t be changed. Otherwise mu-plugins is the best solution. To use mu-plugins, go to /wp-content/ and find the folder with name 'mu-plugins'. If there is no folder in that name, then create a folder, name it 'mu-plugins', create a file inside that, give any name you like and paste the code in there. You don't need to activate that plugin. Mu-plugins means must use plugins, so it will be activated automatically always. If you use mu-plugins then add a php start tag at the beginning of the code.

    About the gcal issue, would you please make sure the followings?

    1. You are not using primary calendar
    2. The time zone is same in gcal settings and general settings from Settings > General.

    If yes, then please send me your ftp and admin login, I will try to connect with my test calendar.

    To send me details, please use our contact form: https://premium.wpmudev.org/contact/

    Select: I have a different question
    Subject: Attn-Ash
    Details: Send all required details (admin info and ftp details) with a link of this thread, so that I can track.
    Also post a note here once you send the info.

    I will be happy to take a look :slight_smile:

    Cheers
    Ash

  • Ash

    Hello @ilanaguttman

    I have just tested with my gcal and it worked perfectly fine :slight_smile: Please check screenshot.

    I think I found the issue in your site. In you settings, "Service account email address" you have put the your gmail address, but it needs to be the service account email address that should last with "@developer.gserviceaccount.com".

    You can find the email address if you go to google project and follow the screenshot.

    Hope it helps :slight_smile: Please feel free to ask more question if you have.

    Cheers
    Ash

  • ilanaguttman

    Hi @Ashok,

    I was able to get the @developer.gserviceaccount.com from the client and I entered it in the settings.

    However, I am STILL having problems!!!

    http://www.irgwebsites.com/rifka/book-an-appointment/ is the link to the bookings calendar at hand

    1) If you try to book an appointment for Bet Shemesh, nothing shows up as available. I checked the settings in the backend several times, and there should be availability on Monday and Wednesday between 9am and 2:30 pm.

    2) In order to test synchronization GCal -> A+, I had the client schedule an appointment for 11:30am tomorrow, Jan. 21 at 11:30am which is one of the times she typically takes appointments. It still shows up as available on A+.
    When I checked the Appointments List and Reserved by GCal tab, it's reserved it under "Financial Consult Bet Shemesh" but really if it's marked on GCal it should reserve the space for any calendars and not allow appointments to be booked. In any event I do not see this on the front end.

    3) I wasable to book a test appointment for Jan. 28 using the A+ interface successfully and that registered fine on the A+ front end, in that the time slot now shows up as busy. However, if I log into GCal, that appointment doesn't show up!!

    I think what's happening is that GCal isn't synching with all of the service providers and it's only synching with one, Rifka-Bet Shemesh which is associated with the Bet Shemesh location. And that one has a bug, as no appointments ever show up as available.

    Please take another look. I've been unable to get this calendar up and running for a very long time now.

    I have reenabled the WPMU Dev Support access.

    Thank you for your assistance.

    Ilana

  • Ash

    Hello @ ilanaguttman

    I hope you are well today.

    1) If you try to book an appointment for Bet Shemesh, nothing shows up as available. I checked the settings in the backend several times, and there should be availability on Monday and Wednesday between 9am and 2:30 pm.

    If I go to Appointments > Appointments > Reserved by GCal I can see there are lots of appointments and the slots are booked already, so you can't book the same slots from the front end.

    When I checked the Appointments List and Reserved by GCal tab, it's reserved it under "Financial Consult Bet Shemesh" but really if it's marked on GCal it should reserve the space for any calendars and not allow appointments to be booked. In any event I do not see this on the front end.

    In that case, I will recommend to use different google calendar for different service provider. When every providers use the same gcal, then it the system block only one provider's slot.

    To allow your service providers to use their own calendar, you need to go to Appointments > Settings > Google Calendar > Select "Yes" from "Allow Service Providers for Google Calendar API Integration". Once you enable this, your providers will be able to provide their key file name, email address etc from their profile page. They also need to give the key file to you so that you can upload via ftp.

    3) I wasable to book a test appointment for Jan. 28 using the A+ interface successfully and that registered fine on the A+ front end, in that the time slot now shows up as busy. However, if I log into GCal, that appointment doesn't show up!!

    Please note that, auto sync is not instant. It runs on wordpress cron, so you will need some visitors in your site to run this cron. You can manually sync though from Appointments > Settings > Google Calendar > By clicking on "Import and Update Events from GCal Now" and "Export and Update Events to GCal Now".

    Also, I doubt you provide this service, but I'd like to suggest that we go over this together via Skype. Seems like it would be a more efficient use of our time than messaging back and forth.

    Yes, we don't provide support over skype, though we have some live chat sessions here: https://premium.wpmudev.org/live-support/

    But for this issue, I don't think live chat support will help.

    Also I think some settings are messed up. Is it possible to reconfigure the system? If you let us know the services, working hours, price etc we can help you with that.

    Please let us know.

    Cheers
    Ash

  • ilanaguttman

    1) If you try to book an appointment for Bet Shemesh, nothing shows up as available. I checked the settings in the backend several times, and there should be availability on Monday and Wednesday between 9am and 2:30 pm.

    If I go to Appointments > Appointments > Reserved by GCal I can see there are lots of appointments and the slots are booked already, so you can't book the same slots from the front end.

    When I checked the Appointments List and Reserved by GCal tab, it's reserved it under "Financial Consult Bet Shemesh" but really if it's marked on GCal it should reserve the space for any calendars and not allow appointments to be booked. In any event I do not see this on the front end.

    >> In that case, I will recommend to use different google calendar for different service provider. When every providers use the same gcal, then it the system block only one provider's slot.

    To allow your service providers to use their own calendar, you need to go to Appointments > Settings > Google Calendar > Select "Yes" from "Allow Service Providers for Google Calendar API Integration". Once you enable this, your providers will be able to provide their key file name, email address etc from their profile page. They also need to give the key file to you so that you can upload via ftp.

    —— No, sorry, not going to do this. My client is actually just one person who works in different locations on different days, and this was the best way to set it up. I’m not going to have her also set up multiple google calendars. This is getting out of hand.

    3) I was able to book a test appointment for Jan. 28 using the A+ interface successfully and that registered fine on the A+ front end, in that the time slot now shows up as busy. However, if I log into GCal, that appointment doesn't show up!!

    >>Please note that, auto sync is not instant. It runs on wordpress cron, so you will need some visitors in your site to run this cron. You can manually sync though from Appointments > Settings > Google Calendar > By clicking on "Import and Update Events from GCal Now" and "Export and Update Events to GCal Now".

    Yes, I know it doesn’t sync automatically. I tried synching manually AND waiting 10 minutes, and it still doesn’t show up.

    Should I just give up already? Or will this thing work?
    Yes, as before you’re welcome to go and test it out yourself.
    Once again I’m sending a link to the appointments.
    https://www.dropbox.com/s/6krbi57fupnf4at/appointments%20schedule.xlsx?dl=0

  • Ash

    Hello @ilanaguttman

    Okay, as I am reconfiguring the system let's start from beginning. I have set the working hours based on three services. I have disabled location and padding add on, as I think they are not needed in this scenario. For some weird reason, break hours were being applied to the calendar even it is set to NO.

    Please, check the hours and calendar without changing anything in the backend and if any issue let us know.

    Once you confirm that, I will check the gcal issue again.

    Cheers
    Ash

  • ilanaguttman

    Hi @Ashok,

    I don't know what is going on anymore. The current configurations were as per intial recommendations from @Michael Bissett. If they need to be changed again in order to get this to work, fine, but I'd like to understand once its working what is going on.

    I am unable to fully test how it works right now if I put an appointment on the google calendar because only my client has access to it. But if I look at an existing appointment, for instance on Jan. 25 there is an appointment from 10-11:30. Therefore, someone shouldn't be able to book an appointment either at 9 or at 11 on that date on the website, because each appointment is to be 90 minutes long with 30 minutes of padding in between (i.e. 9:30-10:30 and 11-12:30 and so on) but they can! Please see attached screenshots.

  • Ash

    Hello @ilanaguttman

    I hope you are well today.

    I have said in my earlier reply, please do not test gCal issue yet, once you confirm the working calendar then I will move again to gcal.

    Once you confirm that, I will check the gcal issue again.

    I have set the working hours and connected with my gcal once,
    https://premium.wpmudev.org/forums/topic/i-have-a-client-with-the-following-needs-on-monday#post-802265 but I think your client somehow messed it up :slight_frown:

    So, let's fix the issues one by one.

    The current configurations were as per intial recommendations from @Michael Bissett.

    I have no idea why! I have configured the hours in your site and you confirmed it here:
    https://premium.wpmudev.org/forums/topic/i-have-a-client-with-the-following-needs-on-monday#post-802303

    Any reason that is changed?

    I have set the working hours again according to your dropbox file, but this time in your site I saw the service hours are 120 mins (it was 90 mins + padding 30 mins before). So, I removed all padding as those are not needed when the service duration 120 mins. You dont need location add on in this case as well. Would you please let me know should I work with duration 90mins + 30mins padding or duration 120 mins?

    I will be happy to reconfigure again, if needed. But I really want it to get solved for you.

    Cheers
    Ash

  • ilanaguttman

    I have said in my earlier reply, please do not test gCal issue yet, once you confirm the working calendar then I will move again to gcal.

    Once you confirm that, I will check the gcal issue again.

    I have set the working hours and connected with my gcal once,
    https://premium.wpmudev.org/forums/topic/i-have-a-client-with-the-following-needs-on-monday#post-802265 but I think your client somehow messed it up :slight_frown:

    I'm not going to be able to get access to her Google Calendar because she has privacy concerns. So please tell me what exactly we will need to do and I can go over it with her one by one. As far as I can tell it is set up correctly.

    So what please would you like me to confirm vis-a-vis GCal?

    So, let's fix the issues one by one.

    The current configurations in the shortcode were as per intial recommendations from @Michael Bissett.

    I have no idea why! I have configured the hours in your site and you confirmed it here:
    https://premium.wpmudev.org/forums/topic/i-have-a-client-with-the-following-needs-on-monday#post-802303

    Any reason that is changed?

    Maybe we aren't talking about the same type of configuration, but I've been following instructions from you and Michael all along and I haven't changed the settings since then. I followed Michael's recommendation for the shortcode. You helped me with some php.

    I have set the working hours again according to your dropbox file, but this time in your site I saw the service hours are 120 mins (it was 90 mins + padding 30 mins before). So, I removed all padding as those are not needed when the service duration 120 mins. You dont need location add on in this case as well. Would you please let me know should I work with duration 90mins + 30mins padding or duration 120 mins?

    When I noticed that there didn't seem to be padding between appointments I added it back in. I don't understand how A+'s calculation works. What I need to end up happening is that there are 90 minute appointments with 30 minutes in between. So please set it up however we need in order to make that happen, but if the duration is 120 min and there is no other setting selected then I don't see how we will get the 30 min. padding.

    I hope that this feedback will allow you to get to the root of the issue.

    Thank you.

  • Michael Bissett

    Hey @ilanaguttman,

    When my colleague Ashok said this:

    Would you please let me know should I work with duration 90mins + 30mins padding or duration 120 mins?

    I believe he meant to ask, would you rather:

    - Have each of the services set to a 90 minute service duration, with 30 minutes of padding added?
    - Have each of the services set to a 120 minute service duration?

    From what you said earlier, it sounds like either one would be suitable for you. Just as a note, were we to set the duration to 120 minutes, in order to have them come up as 90 minutes on the front end, the following PHP code will need to be inserted as a mu-plugin:

    function modify_duration_text( $text, $duration ) {
    return ($duration -30) . ' minutes';
    }
    add_filter('app_confirmation_lasts', 'modify_duration_text', 10, 2);

    I've called my colleague @Ashok back to the thread, so that he can advise on his plan to deal with GCal. :slight_smile:

    Kind Regards,
    Michael

  • Ash

    Hello @ilanaguttman

    I hope you are well today :slight_smile:

    I have set 90 mins appointment with 30 mins padding, please check the calendars and confirm if it doesn't work.

    About the gCal issue, I went to check through FTP, but it seems the directory is changed. I checked "hanakatova" folder, but there is no appointments plugin in the plugins folder. Would you please let me know the correct directory name? I will test again with my gCal app.

    Please let me know.

    Cheers
    Ash

  • ilanaguttman

    Hi @Ashok,

    Maybe you're confused with another website I submitted a request for? This isn't the hanakatova website. In any event, the client created a test event for this Thursday using synched calendar. (see screenshot)
    But if I look at the calendar on the live site, I can still schedule appointments during the times that she is busy on the Google Calendar...

    I will send you the correct FTP login credentials for this website again via the contact form.

    Thank you!

  • Ash

    Hello @ilanaguttman

    I hope you are well today and thanks for sending FTP details :slight_smile:

    So, the working calendar looks okay now from front end?

    About the synchronization from gcal to A+, when you will have multiple providers, the system can't block any slot as it is not sure whose slot should be blocked. So, it is just imported into you system, and you can see from Appointments > Reserved by GCal.

    I am including @Hoang Ngo in this thread, I think he worked on something like this, so that at least it can be assigned into one provider. But this is not possible out of the box.

    And, does synchronization from A+ to GCal work?

    Cheers
    Ash

  • ilanaguttman

    Hi @Ashok,

    It works okay on the front end, but as I have explained previously, it is one provider who works in different locations at different times. It is not feasible for me to set up more than one google calendar for her. Why can't the system import the selection for "all provider"? That is after all one of the options in the backend when you choose working hours.

    A MAJOR reason why I purchased WPMU dev was for this plugin, and a MAJOR reason why I wanted this plugin was because it claimed that it could synchronize both ways with Google Calendar. But it looks like this is in the end not the case, at least not in the way that I need.

    I'm extremely disappointed, after spending hours of time and also some money getting this set up.

    In the end, if my client can't block off time from Google Calendar, honestly, this is probably useless, because people schedule appointments with her not just through the website.

    Does synchronization from A+ to GCal work?
    Not always.
    As a test I scheduled an appointment for 11:00am on Jan. 29 and it doesn't show up on the Google Calendar.
    I'm giving this 24 more hours and then I give up. I appreciate your attempts to help me but this is out of control.

  • Ash

    Hello @ilanaguttman

    In your case, you are using the calendar globally with your admin calendar. You have three providers. Now, if your admin blocks a slot from gCal, then in your A+ system which provider's should be blocked? As this can't be determined, so the no slot is blocked in this case. But the event is imported what you can see from your appointment list.

    So, there are two ways. One is to use one provider for all service and that is not possible in your case. The other one is to use different google calendar for all providers. To do so, you need to allow your providers to set their gcal integration. Note that, in this way all providers will have different calendar and that will be owned by themselves. Also, note that, as you are admin and only you have the ftp access, so they need to send the key file to you and you need to upload the key file into correct folder. To allow your provider to use their own calendar, you need to go to Appointments > Settings > Google Calendar and select YES for "Allow Service Providers for Google Calendar API Integration". Then your providers can set their gcal from their profile page.

    As a test I scheduled an appointment for 11:00am on Jan. 29 and it doesn't show up on the Google Calendar.

    It won't be instant. To make it instant, after making a booking, you need to manually export booking from A+ to GCal from google calendar settings page.

    Also, please make sure the time zone of the calendar and the site Settings > General is same and the calendar is not a primary calendar.

    As this is your client's gcal, would you please configure with one of your calendar to test this?

    Cheers
    Ash

  • ilanaguttman

    But... it's ONE PERSON. So to have her manage 3 different Google Calendars is crazy and really inconvenient. I'm not going to ask her to do that, because she isn't going to want to.
    It's one person, who works in different locations, on different days. And that's why I have it set up as multiple service providers, even though it's really one person.

    As a test I scheduled an appointment for 11:00am on Jan. 29 and it doesn't show up on the Google Calendar.

    >>>It won't be instant. To make it instant, after making a booking, you need to manually export booking from A+ to GCal from google calendar settings page.

    Yes, I manually exported it and it still doesn't show up! And now, over an hour later, I checked again and it still hasn't shown up on GCal.

    The time zone settings have already been checked and are in sync.

  • Ash

    Hello @ilanaguttman

    Well, she is one person, right, but the system doesn't know one person. The system knows 3 persons as there are three different accounts. So, the system will treat them as three persons.

    So, do you want to book slots from three service providers when a slot is booked in gCal?

    Also, a SLS developer @Hoang Ngo is already flagged. He will take a look as soon as possible.

    Cheers
    Ash

  • ilanaguttman

    Well, she is one person, right, but the system doesn't know one person. The system knows 3 persons as there are three different accounts. So, the system will treat them as three persons.

    I get that, but what I'm saying is that's not a viable solution for you.

    So, do you want to book slots from three service providers when a slot is booked in gCal?

    YES!

    Also, a SLS developer @Hoang Ngo is already flagged. He will take a look as soon as possible.

    I appreciate that. Thank you.

  • ilanaguttman

    Hi @Hoang,
    I followed your instructions and uploaded that attachment to the correct directory, overwriting the old file, but I don't think this is working. See attached screenshots. I reserved a test meeting on the Google Calendar for Feb. 11 from 9-10am - item ID 66. I ran "export from GCal to A+" and I was still able to schedule an appointment for Feb. 11 at 9am via A+ on the website - item ID 69.
    Also see attached screenshot of the Google Calendar. You can see it allowed me to "double book". Any final suggestions? My deadline for finishing this is tomorrow.

  • Hoang Ngo

    Hi @ ilanaguttman,

    I'm sorry about this, here is the steps to make it work.

    1. You will need to enable Allow Service Providers for Google Calendar API Integration in Appointments Settings->gCal settings
    2. In each Service Providers profile page, you will need to enter the parameters (Key file name,Service account email address,Calendar to be used) same with your settings in gCal Settings.
    This will make all Service Providers sharing same calendar
    3. For now, the auto sync will work (interval about 10 minutes). For making manual sync working, please use the new version I attached here.

    If you have any issues please don't hesitate to let us know so we can assist

    Best regards,
    Hoang

  • ilanaguttman

    @pxwm - THANK YOU!!!
    ::facepalm:: of course I need to be logged in as the user. I've been dealing with this issue so long I cannot think outside of the box at all.
    I think everything is working now.
    I'm going to try this out again with my client's calendar instead of my own test calendar. I've bought myself a little bit more time so I should be able to try this again with fresh eyes tomorrow.

    Thank you @Hoang, @Ashok, and @pxwm!

    I will confirm results tomorrow. (I am UTC+2)

  • Hoang Ngo

    Hi @ ilanaguttman,

    I has added a new file in /wp-content/mu-plugins/app_custom_code.php, which enable admin to edit user fields from Appointments.

    And add this line of code

    if(current_user_can('manage_options'))
                    $is_readonly='';

    To the file gcal.php, line 415.

    Also, line 3350 file appointments.php

    if ( $current_user->ID != $profileuser_id)
    			return;

    To

    if ( $current_user->ID != $profileuser_id && !current_user_can('manage_options'))
    			return;

    This should work fine now :slight_smile:

    Best regards,
    Hoang

  • ilanaguttman

    @Ashok, @Hoang
    Well, I finally had a chance to go over this with the client again now that I moved all new changes to the live site, and... it's still broken!!!!

    A test appointment was booked for Feb. 22 at 9am and it does not show up in Google Calendar (both after 10 minutes went back and it was manually sent).
    It worked in the test that we did, but it's not working on the client's calendar. I double checked that her calendar info is correct.

  • Patrick

    Hi there @ilanaguttman

    I hope you're well today!

    As you have now moved everything over to a different site, have you double-checked the following?

    Is the Google calendar information entered in the plugin settings as the main calendar to be used by the plugin? It won't work right if that info is simply added to the user profile as service provider.

    Also, have you ensured that you have selected the appropriate integration mode?

  • ilanaguttman

    Hi @Patrick,

    Is the Google calendar information entered in the plugin settings as the main calendar to be used by the plugin?

    Yes, and all of the users have the same settings: key file name, calendar, and service account email address

    Also, have you ensured that you have selected the appropriate integration mode?

    Yes, A+ <->GCal

    I hit "test connection" and didn't receive an error, but nor did I see a test appointment starting in 30 minutes.

  • Hoang Ngo

    Hi @ilanaguttman,

    I hope you are well today.

    I would like to take a look at your backend again, Can you please send in:

    - Mark to my attention - ATTN: Hoang Ngo
    - Link back to this thread
    - Include admin/network access
    - Include FTP (I've checked the old FTP you sent to Ash, but it not working anymore)
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    Thanks!!.
    Hoang

  • ilanaguttman

    Hi @Hoang,
    When I try to set WP_Debug to true, I get the following error message: "Server said: wp-config.php: Permission denied
    Error -160: could not start data transfer"
    This is no longer my website so I don't have the same level of access.
    What can I do?

    There is an appointment in the system for Feb. 22 at 9am, for instance, but it does not show up on the Google Calendar. Same with Feb. 25 at 9am and 11am.

  • ilanaguttman

    Another strange thing is happening. I had created a test Google Calendar on my own account in order to test the calendar when I had it on the other website, the development website. I have since changed back the settings to my client's Google calendar. I double and triple-checked that I have her Google Calendar details saved in A+ but when I booked a test appointment for Feb. 18, it is showing up on MY test calendar and not on my client's. I even deleted the old key. I can't figure out what's going on anymore.

    Also, the test connection doesn't work for the client's calendar. I just checked the settings yet again and it looks correct.

  • Hoang Ngo

    Hi @ilanaguttman,

    So I think we should check with your client, and ask for adding this code to the wp-config.php

    define('WP_DEBUG', true);
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Please make sure that they remove the old
    define('WP_DEBUG', true);
    Before add the new code. That's for logging the error.

    Like I said before, when I do the debug, no error return, so we still don't have any clues :slight_frown:. That's why I to enable the error logging first.

    Also, does it fine if I use my calendar for test?

    Best regards,
    Hoang

  • ilanaguttman

    Hi,
    It's not a matter of contacting the client. She won't know what to do with this. I'd need to contact her host, and frankly I'm tired of all of the time I have sunk into this. I don't see the point of testing with your calendar or another one of my test calendars again. I keep giving this another chance, and at the end of the day, it just doesn't work the way it is supposed to.
    I give up and am searching for alternative options.
    I appreciate your attempts to help me, but after 7 weeks of working on this, and a project past deadline, I can't continue to work with this plugin.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.