i have a Databasefile created in mysql 5.6 and exported it.

Hi,
i have a Databasefile created in mysql 5.6 and exported it. I was trying to import it in a mysql 5.7 database. The import allways fails whit an error. How can i fix this issue?
Thanks!

  • eberhardgross
    • Site Builder, Child of Zeus

    Hi,
    her's the text in german:
    Es wurden keinen Daten zum Importieren empfangen. Entweder wurde keine Datei ausgewählt, oder die Dateigröße hat die maximal erlaubte Größe der PHP-Konfiguration überschritten. Siehe FAQ 1.16.
    I translate: No data was received to import. Either no file has been selected, or the file size exceeded the maximum allowable size of the PHP configuration. See FA

  • Rupok
    • Support Ninja

    Hi eberhard

    Hope you had a wonderful day.

    Can you make sure the new database where you are trying to upload your dump, has characterset support for your previous MySQL Dump? Can you change your DB collation to "utf8_general_ci" and try again? To get more idea, you can check this article: https://dev.mysql.com/doc/refman/5.7/en/charset-applications.html

    Please let us know how it goes. If you still face the issue, can you upload the backup dump to any common file sharing service like Dropbox, Google Drive etc. and send me message with download link through our secure contact form here: https://premium.wpmudev.org/contact/ so we can try importing it to our test instances and try to regenerate the issue and fix it if possible?

    Subject: "Attn: Rupok"
    - Dump Download Link
    - Link back to this thread for reference
    - Any other relevant URLs

    Select "I have a different question" for your topic. This and the subject line ensure that it gets assigned to me.

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi eberhard, hope you had a wonderful day.

    I checked in my test server with MySQL 5.7 installed. I got the same error first, but changing Maximum File Size for Uploading in PHP configuration solved it for me. To change it on your server, open your php.ini file, find the following definition:
    upload_max_filesize
    Probably default value is 2M. Change it to 20M. Then restart apache. Now try to import again. It will work.

    Please let us know if you are stuck at any certain point. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.