504 Gateway Timeout


I have a particular website that's starting to give me login issues. I'm getting this error "504 Gateway Timeout" more often now everytime I log in to my wordpress sites. Most of my sites are multisite installation. I know for a fact that the issue is the WPMUDEV Defender plugin. I really like that plugin but if it's going to give me this error all the time I'm going to stop using it.

Is there any workaround to this issue? I'd like to keep using the defender plugin...

  • Nithin

    Hi Simplebutcreative Media,

    Hope you are doing good today. :slight_smile:

    504 Gateway timeout error means, that there is an issue with responses from one server to another. Could you please try increasing the max_execution_time, and then check whether that helps?

    You'll have to create a php.ini file in your root directory, and add the following rules in it:
    max_execution_time = 300

    The root directory is where /wp-content, /wp-includes, /wp-admin folders reside. You can check whether the values gets increased, or not via the WPMU DEV Dashboard, under WPMU DEV > Support > SYSTEM INFO

    If you aren't able to increase max_execution_time, would recommend you to get in touch with your host to increase these values behalf from your side. If increasing the value doesn't help, please enable support access, so that we could give a closer look.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice weekend. :slight_smile:

    Kind Regards,