I have a problems with SEO optimization in Upfront

I’m using Upfront and I have a problems with SEO optimization. I couldn’t find where to put key words and description, it’s available only for pages. Maybe you can help me with that?

  • Luís
    • Support

    Hi Natali ,

    Hope you're doing well today!

    Upfront already allows to add the meta description in the page/post, through the left sidebar -> Post/Page Settings:

    However, to add the meta keywords we need to use the default WordPress editor. If you are using our SmartCrawl plugin, you can edit the post and add your keywords in the "SmartCrawl" section:

    If this is not working on your website, can you give us access to your admin panel, so we can check your issue?

    If you don't already know, please, follow the link below, to see how enable the staff login:

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    When you enable this option, please post again!

    Cheers, Luís

  • Natali
    • WPMU DEV Initiate

    Is Mets descriptions only for posts? What can I do for this one?

    I'll try to explain the problem.

    I have a site at Upfront http://misscupcake.in.ua/ - it's my main page and I don't understand how and where should I put meta descriptions, key words exactly for this address.
    I understand how to work with Pages and SmartCrawl, but I don't use pages like this http://misscupcake.in.ua/about/ at my site. I'm interesting only in http://misscupcake.in.ua/ SEO

  • Luís
    • Support

    Hi Natali ,

    Hope you're doing well today!

    I would like to apologize for the incomplete information given in my first reply.

    The "Homepage" in Upfront is a "virtual" page, is not a normal page accessible in the "Pages" section and at the moment, we cannot add the description in this page through the Upfront Editor like the other pages and posts.

    Our developers are aware and working in a better way to handle with this.

    To add the meta tags (Title, description, keywords) to the homepage, we need to do this in Smartcrawl.

    1) Go to Settings -> SmartCrawl -> Step 3: Title & Meta;

    2) In the "Home" section, add your meta tags.

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

    • Natali
      • WPMU DEV Initiate

      I have one more question))
      What if I have Multisite. In my main admin panel I have such options you had describe, but when I switch to All Sites - chose one of my sites - open its own control panel -> there, I have no SmartCrawl at Settings. It appears only on Pages or Posts, like a tool for each page/post.

  • Luís
    • Support

    Hi Natali ,

    Hope you're doing well today!

    In a Multisite environment, the access to SmartCrawl "per-blog mode" is not enabled by default. Only the network admin (through the network admin panel) are able to change and define settings.

    Please check the plugins usage page, in the "Enabling Access on Sub-sites" section.

    To enable the "per-blog mode", you need to:

    1) In the end of each tab of the SmartCrawl, you have a setting called "Allow Site Admin access".

    Change the box to "Yes" on the tabs you wish to give subsite admins access to.

    2) Finally, add this define to your wp-config.php:

    define( 'WDS_SITEWIDE', false );

    After that, you should be able to access to SmartCrawl in all sub sites (under the Settings menu item).

    I hope this information has been helpful. If I can help you in this or other questions, please let me know!

    Cheers, Luís

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.