I have a question.

Hey guys I have a question. We just recently moved over to https for our multisite. Everything has been switched over successfully, and the template we are cloning from uses https for everything I can see.

Once we clone that template, the new site looks exactly the same (everything is https). The issue that has arisen is that when we go to manually upload new images to the site, those do not upload as https.

Even the backend library is then showing mixed content as a result. Is there something we are missing or need to change in order to make sure new images added to cloned sites are also marked as https automatically?

Thanks!

  • Jeff
    • Design Lord, Child of Thor

    Correction…all image links within the media library of newly cloned sites are set to http://

    This is NOT the case for the site we’re cloning from. Those images are listed as https://

    This breaks on newly cloned sites.

    Images that are referenced on the front end are changed to https successfully, however. It is only brand new images that don’t.

  • James Morris
    • WordPress Enthusiast

    Hello Jeff,

    I hope you are well today.

    I would have to see your network dashboard to be completely sure what’s going on, but it sounds like you are using a plugin to do the conversion from HTTP -> HTTPS rather than a database change. Is this correct?

    If that is the case, any new sites you create will have HTTP as the setting in the backend, thus creating the issue you are seeing.

    In order to help you better with your issue, would you please grant me access to your site?

    You can learn how to grant WPMU DEV Support Access at the following link:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please reply back here once you’ve enabled access so I will be notified.

    Best regards,

    James Morris

  • Jeff
    • Design Lord, Child of Thor

    Hey guys just making sure you saw my last post. I have given you admin access to the site along with all the details. I can’t figure out why the cloner is reverting back to http:// when the site that it’s being built from is all https:// (including database tables from what I can see).

    What setting are we missing? Thanks1

  • Jeff
    • Design Lord, Child of Thor

    To be honest I don’t know.

    The “site address” for the main domain is still showing http:// from the “info” tab. However, from the “settings” tab it is showing https:// for both the siteurl and home url.

    All other subdomains have https:// for both the “info” tab and “edit” tab.

    We made changes to our htaccess file. All subdomains point to public html. We are not using any plugins other then the one my programmer made to push over our mapped domains to https because we’re using the mu domain mapping plugin.

    If there is something you feel we’re missing there please let me know. Thanks!

  • James Morris
    • WordPress Enthusiast

    Hello Jeff,

    I have been testing this issue out on your site as well as my own SSL Multisite install. I’ve been unable to reproduce the issues you are seeing on my test site. In order to help you better with your issue, would you please grant me access to your site and server?

    Please visit the Contact page and complete the form with the following information:

    Subject: “Attn: James Morris”

    In the Message box, please provide the following:

    – link back to this thread for reference

    – any other relevant urls

    – Admin login:

    Admin username

    Admin password

    Login url

    – Domain Registrar Login

    Admin username

    Admin password

    Login url

    – Hosting Control Panel Login

    Admin username

    Admin password

    Login url

    – FTP credentials

    host

    username

    password

    (and port if required)

    Best regards,

    James Morris

  • James Morris
    • WordPress Enthusiast

    Hello Jeff,

    The “site address” issue you are seeing is a known bug. See: https://core.trac.wordpress.org/ticket/39786

    This will be fixed in the next major version of WordPress.

    The symptoms I’m seeing on your site indicate an issue in the database, though. Our team is currently testing this out on an setup similar to yours. Once we have access to your server, we can further determine the exact source of the issue.

    Best regards,

    James Morris

  • James Morris
    • WordPress Enthusiast

    Hello Jeff,

    I’ve been working with our SLS team and me and 2 other staff members have tested out numerous scenarios. What we have found is as follows:

    Whether you create a site via Cloner or through the native WordPress Multisite Add New site button, the protocol (http/https) is ignored and the new site is created as http. This, however is only happening on subdomain multisite installs instead of subdirectory installs.

    The reason for this behavior is that subdirectory installs are just treated as that, a subdirectory. So, whatever protocol is used for the primary domain will be used on the new subdirectory subsites.

    However, with subdomain subsites, they are treated as an entirely new domain and WordPress does not assume that https is supported, and therefore defaults to the http protocol as it is certain to work (https will not work on some hosts if a certificate is not present). This is most likely an intentional feature rather than a bug.

    So, because WordPress does not honor the protocol when creating a new site, Cloner does not either because it uses the WordPress routines to create new sites. The differences is it clones over the settings, plugins and themes.

    What we’ve found is, as part of your cloning/adding new procedure, all you need to do is go to Network Admin -> Sites -> Hover over the site you just created and click Edit. Once in the Edit page, change the protocol from http to https and everything will work correctly. I’ve verified this on a test site I created on your network.

    I hope this clarifies a bit. Let us know if you have any further questions. We’ll be happy to help! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.