I have been trying

Hello,

I have been trying to get help with this issue and cannot seem to get a response. I cannot use Snapshot to a remote storage or locally. I keep getting the following error:

ERROR: PclZIP table: Array: add failed : -4: File 's3:disappointed:...snapshots/_backup/1474327206/wp_usermeta.sql' does not exist [code -4]]

I really need to get this running.

  • Rupok

    Hi Russell Ernst ,

    Thanks for asking. I searched with your issue and it seems like it's a very rare issue. However, to troubleshoot the issue, can you turn on debug mode in WordPress? To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    Past errors here. If file is very long, paste them to a text file and attach with your reply.

    This also could be a memory issue. Can you try adding this to your wp-config.php file?

    define('WP_MEMORY_LIMIT', '256M');

    Can you also turn on log in Snapshot and try running the process again? To enable log, please go to "Dashboard > Snapshot > Settings" and scroll down to "Error Reporting" section. There you will see three options to log. Check each of them. Please check the attached screenshot for reference.

    Please enable error log and provide us log data. At the far right of each snapshot listed, you can view or download the log of all actions performed during the backup.

    That could give us more info regarding what is causing the issue. I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Client

    I've added the information to the config file.
    I am still getting the same error. One thing is I am not sure why it's giving me an s3 error even though I'm trying to save the backup to the local server itself.

    Also, I do not get the option "Include selected files:" as an option when trying to perform a snapshot on any sites that are not the primary sites ( rebootmedia.agency ).

    The site I have been trying to create a snapshot of, is kataliya.co. I am trying to move this site out of multisite into it's own site.

    Thank you