I have been trying to install then activate any

I have been trying to install then activate many of the templates from WPMU any time I do I get this...

Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/www/seniorcitizennetwork.com/wp-content/themes/upfront/library/servers/class_upfront_javascript_main.php on line 229 . I tried 3 times turning off plugins and removing some unused themes and reinstalling but that did not help. And also it would sometimes say the parent theme is missing.

Can someone explain to me whats going on.
Thanks for your time,
Michael