I have been working with David in your sales department

I have been working with David in your sales department to get an answer to my issue (it was originally a pre-sales question). It looked like your plugin would do what I need it to do, but it's not doing what it's supposed to do and David hasn't followed up with me so I thought I'd try submitting my issue directly to support.

1. I have a custom post type called "property"

2. In each post I have an address field, city field and state field.

3. I want to have a "page" that has a Google Map on it that shows all of the locations for a particular US state, "Ohio" for instance.

4. I have selected "yes" in your plugin for "use custom post meta fields support".

5. I have set up my field names in the "My posts have an address field" like this: prop_address, prop_city, prop_state (my actual field names in the 'property' custom post type)

6. I tried to do a query as David suggested as [map query="tag=Ohio"], I get no map, no nothing. I also tried [map query="post_type=property"] and [map query="post_type=property&meta_value=Ohio"] also without any luck.

Can you please help me with this? It's critical to this project and I only have another week to find a solution. I bought your plugin with the understanding that it would do what I asked. That's why I reached out to sales BEFORE I purchased the plugin.
Thank you,
Dave Muhr

  • Patrick

    Hi there @Dave

    Welcome to WPMU DEV, glad to have you aboard!

    I just tested setting things up on a test site similar to yours here:
    http://classifieds.patrickcohen.net/map-test-2/

    Using a custom post type called testtype, and custom fields like yours, the following shortcode successfully displays a mashup of posts:
    [agm_map query="post_type=testtype&meta_value=Alabama" width="100%" zoom="5" overlay="true" show_images="false"]

    If you are still having difficulty getting your mashup to display, please enable support access from your WPMU DEV Dashboard as described here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    We'll be happy to login to your site to help you get this sirted.

    Thanks!

    • Dave

      Patrick, I've tried your solution, using my criteria of course. When I use "[agm_map " to begin the shortcode I don't get a map at all, I just get the shortcode text displayed. If I change it to "[map " then I get a map, but with no markers at all. Here are the two shortcodes I tried:
      [agm_map query="post_type=property&meta_value=Ohio" width="100%" zoom="5" overlay="true" show_images="false"]
      [map query="post_type=property&meta_value=Ohio" width="100%" zoom="5" overlay="true" show_images="false"]

      I've turned on Support Staff Access.

  • calvinrogercanas

    Hey there @Dave,

    Hope you're well! :slight_smile:

    You can find the option to change the shortcode here: Admin -> Settings -> Google Maps -> Options -> (at the bottom) Change Shortcode like this: http://prntscr.com/66ry98

    then you can now use the shortcode provided by @Patrick

    Could you grant support access from the dashboard plugin in order for me to take a closer look. See https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Looking forward for your reply! :slight_smile:

    Best Regards,
    Calvin

  • Dave

    @Calvin, thanks for helping. I can't disable the plugins on the active site, because that would impact what people are seeing too much. So I set up a testing server and moved all of my content there. I'm using the Twenty Fifteen theme. I've disabled all plugins except for Advanced Custom Fields, IRG Properties and Google Map. Then I add the map to my page with this shortcode:
    [agm_map query="post_type=property&meta_value=Ohio" width="100%" zoom="5" overlay="true" show_images="false"]

    And again, the map displays, but no markers are attached to the map.

    I'd like to grant you support access so that we can work on this server, but the WPMU dashboard is telling me that I can't grant "This site is not enabled for support. " So I went and removed the WPMU dashboard and Google Maps from the original site, hoping after I did that I could grant you access, but the button is still grayed out. What can we do? I can't upgrade my subscription just for testing. And when we get it working and I move it back to the IRG website I need to have that be the subscribed to URL. Help!

  • Dave

    @Calvin, as an experiment, I added a "tag" to the regular post type of "ohio", and tagged on of the posts. Then I did a shortcode as: [agm_map query="tags=ohio" width="100%" zoom="5" overlay="true" show_images="false"]
    And the marker showed up on the map. So I added a tag to my custom post type for "ohio" and gave a few of the custom posts the "ohio" tag. Then reloaded the page. I would have thought that the tagged custom posts would have shown up, but they didn't, only the one from the normal posts did. So I'm wondering, is there something wrong with my custom post type? I've attached the file that I built as a plugin to add my custom post type to my system. Could there be something wrong in there that's screwing up the system?

    I also tried this shortcode, I get the map with no markers, I'm trying to force it to find the custom post properties:

    [agm_map query="post_type=property&tags=ohio" width="100%" zoom="5" overlay="true" show_images="false"]

  • calvinrogercanas

    Hey there @Dave,

    Hope you're well! :slight_smile:

    I will get the test site's credentials thru contact form since the issue show on the site supported by us.

    Can you please send in:

    - In the subject field add "Attn:Calvin Canas"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site
    - Include the php file you are talking to your last reply ( zip it )

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Looking forward for your reply! :slight_smile:

    Take care,
    Calvin

  • Dave

    @Vinod, also, I had set up Calvin as a WordPress user to testing. The server that you were checking is the test server, so if you want to work on my server either use Calvin's login or I can set you up as a user as well. It might be easier to work the problem out on my test server instead of going back and fourth. Once it's resolved on my test server then I can port it to my real site. Let me know.
    Thanks.

  • Dave

    @Vinod Dalvi, hello? Anyone there. It's been a few days and I haven't heard any anything at all. I need an answer to my problem. So far I've had @Dev4, @Vaughan, @Patrick, @Calvin and yourself in on this thread and no one is giving me any help. A month ago when I was considering purchasing this plugin I was told that it can do what I needed to do. I bought the plugin and have reached out repeatedly for support because it doesn't do what I need it to do. Will someone please work with me to resolve this??
    Dave

  • Michael Bissett

    Hey @Dave,

    Please accept my apologies for the delays here, I realize that this has been going on a lot longer than it should've. :slight_frown:

    I've tried to dig into this for you here, and I'm honestly a bit curious here. At the moment, I'm seeing that the markers all show up if I set up the shortcode like this:

    [agm_map query="all" width="100%" zoom="5" overlay="true" show_images="false"]

    However, this does mean that more than just the tagged posts are being displayed here (I realize that you're wanting to display custom posts that have been tagged with a custom tag), but it doesn't seem like using any of the post query parameters seems to be working. :disappointed:

    I've informed my colleagues @Patrick & @Vinod Dalvi of this thread, to see what their thoughts are on this.

    Thanks very much for your patience throughout all of this, it's really appreciated! :slight_smile:

    Kind Regards,
    Michael

  • Dave

    @Michael, thanks for helping me out here. And just to be clear, I'm not trying to load markers for posts with tags, that would be a last resort. What I want is the following:

    1. Each custom post called "property" has custom fields for address, city, state and zip
    2. Post each custom post on one map for only properties in one particular state. For instance, show only the properties in "Ohio". I could end up with 50 maps in the end, one for each state.

    That's it.

    The only reason I have some properties "tagged" (the ones that show up for your "all" shortcode) is that I was trying to force the system to post the properties to a map. Vinod thought that my issue might have been with my PHP code to build the custom post type, see it here:

    /* Plugin Name: IRG Properties
    Plugin URI: http://muhrdesign.com
    Description: Custom plugin for IRG, creates custom post called "IRG Properties"
    Version: 1.0
    Author: Muhr Design
    Author URI: http://muhrdesign.com
    License: GPL2
    */

    add_action( 'init', 'my_custom_post_property' );

    function my_custom_post_property() {
    $labels = array(
    'name' => _x( 'Property', 'post type general name' ),
    'singular_name' => _x( 'Property', 'post type singular name' ),
    'add_new' => _x( 'Add New', 'book' ),
    'add_new_item' => __( 'Add New Property' ),
    'edit_item' => __( 'Edit Property' ),
    'new_item' => __( 'New Property' ),
    'all_items' => __( 'All Properties' ),
    'view_item' => __( 'View Property' ),
    'search_items' => __( 'Search Properties' ),
    'not_found' => __( 'No products found' ),
    'not_found_in_trash' => __( 'No proporties found in the Trash' ),
    'parent_item_colon' => '',
    'menu_name' => 'IRG Properties'
    );
    $args = array(
    'labels' => $labels,
    'description' => 'Holds our properties and property specific data',
    'public' => true,
    'menu_position' => 3,
    'menu_icon' => 'dashicons-shield',
    'supports' => array( 'title', 'editor', 'thumbnail', 'excerpt', 'comments', 'custom-fields' ),
    'has_archive' => true,
    );
    register_post_type( 'property', $args );
    }
    add_action( 'init', 'my_custom_post_property' );

    function my_taxonomies_property() {
    $labels = array(
    'name' => _x( 'Property Categories', 'taxonomy general name' ),
    'singular_name' => _x( 'Property Category', 'taxonomy singular name' ),
    'search_items' => __( 'Search Property Categories' ),
    'all_items' => __( 'All Property Categories' ),
    'parent_item' => __( 'Parent Property Category' ),
    'parent_item_colon' => __( 'Parent Property Category:' ),
    'edit_item' => __( 'Edit Property Category' ),
    'update_item' => __( 'Update Property Category' ),
    'add_new_item' => __( 'Add New Property Category' ),
    'new_item_name' => __( 'New Property Category' ),
    'menu_name' => __( 'Property Categories' ),
    );
    $args = array(
    'labels' => $labels,
    'hierarchical' => true,
    );
    register_taxonomy( 'property_category', 'property', $args );
    }
    add_action( 'init', 'my_taxonomies_property', 0 );

    function my_taxonomies_property2() {
    $labels = array(
    'name' => _x( 'Property Tags', 'taxonomy general name' ),
    'singular_name' => _x( 'Property Tag', 'taxonomy singular name' ),
    'search_items' => __( 'Search Property Tags' ),
    'all_items' => __( 'All Property Tags' ),
    'parent_item' => __( 'Parent Property Tag' ),
    'parent_item_colon' => __( 'Parent Property Tag:' ),
    'edit_item' => __( 'Edit Property Tag' ),
    'update_item' => __( 'Update Property Tag' ),
    'add_new_item' => __( 'Add New Property Tag' ),
    'new_item_name' => __( 'New Property Tag' ),
    'menu_name' => __( 'Property Tags' ),
    );
    $args = array(
    'labels' => $labels,
    'hierarchical' => true,
    );
    register_taxonomy( 'property_tag', 'property', $args );
    }
    add_action( 'init', 'my_taxonomies_property2', 0 );

  • Dave

    @michael, any luck sorting this out?? This is getting ridiculous. I was assured before purchase that your plugin would work. This has been going on for weeks! I was just charged for my second month's subscription and I'm unable to make use of your plugin. WPMU needs to either help me or tell me that the plugin can't do what I want so I can move on to finding another company that can help. Please advise.

  • Michael Bissett

    Hey @Dave, great news! :slight_smile:

    After digging into this further (with the help of the developer, thanks @Philipp Stracker!), the problem turned out to be due to the fact that while the maps were being created for each listing, they weren't being associated to each listing.

    As a result, when we tried running a query on anything but "all", the markers wouldn't show up, since the maps were never associated with any of the posts.

    I've taken care of that for you by setting "Associate the new map to post" to "Yes" inside of:

    Settings -> Google Maps -> Custom Fields

    And after deleting the old maps for you, and re-saving two of your properties, I'm now seeing them show up on your Ohio page when I use this shortcode:

    [agm_map query="meta_key=prop_state&meta_value=Ohio" width="100%" zoom="7" overlay="true" show_images="false"]

    Could you confirm that it's showing up on your end as well please? :slight_smile:

    Kind Regards,
    Michael

  • Dave

    @Michael, thanks for this. Unfortunately I couldn't wait any longer and I had to hire a programmer to build a custom system that meets my needs. I'm two weeks behind schedule on this and I just couldn't wait any longer for WPMU to get an answer. I know it's not your fault personally, but I was frustrated with lack of support on what seems to be a simple solution in the end.

  • Patrick

    Hi there @Dave

    I'm terribly sorry we didn't catch the source of the issue in time for you.

    I also must apologize personally for not having responded to you having mentioned me personally in this thread multiple times. We have been having issues with email notifications for @mentions, and the only 2 I received from this thread actually wound up getting spammed by my filters. :slight_frown: