I have bulked

I have bulked the images several times. I run a report and it still states my images are not optimized. I do not know what else to do. Can you please help.

  • Dimitris

    Hey there Robert,

    hope you're doing good and thanks for reaching us!

    Could you please try to clear and deactivate any caches involving to your installation that might come from plugins, server side mechanisms like Varnish or Memcached, 3rd party services like Cloudflare and your browser cache and give that another spin?

    Please keep in mind that there are some cases where some attachments were being counted in Smush while the actual files have been removed.
    Using the following snippet as a MU plugin should reveal those to you, if any. You can simply insert next code in a file in your server like /wp-content/mu-plugins/list-attachments.php (create the /mu-plugins/ folder if doesn't exist)

    <?php
    add_action( 'admin_init', 'custom_list_attachments' );
    function custom_list_attachments() {
        $list_only = true;
        // $list_only = false; will list & delete the attachments.
    
        $attachments = get_posts("post_type=attachment&numberposts=-1");
        foreach($attachments as $attachment) {
            $file = get_attached_file($attachment->ID);
    	if(!file_exists($file)) {
                if($list_only) {
                    echo '<p><span style="color: red; margin-left: 400px;">ID: ' . $attachment->ID . '</span></p>';
                } else {
                    wp_delete_post( $attachment->ID, false );
                    echo '<p><span style="color: red; margin-left: 400px;">ID: ' . $attachment->ID . ' Removed.</span></p>';
                }
            }
        }
    }

    If this continues, please grant us with support access to your website in order to have a better look inside. You can do so via WPMUDEV Dashboard plugin as described here:
    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Warm regards,
    Dimitris

  • Local Magnetic Maketing

    It did not work. The first graph was pre emailing you. The second data was after email. I deactivated WP fastest cache. After 20 images, I deactivated all the plugins and nothing changed.

    https://artificialturfcorona.com [removed by WPMU DEV staff]

    225/248
    ATTACHMENTS SMUSHED
    ________________________________________
    TOTAL SAVINGS11.4 KB / 0%
    ________________________________________
    ATTACHMENTS SUPER-SMUSHED225/248
    ________________________________________
    RESIZE SAVINGS0MB

    47/248
    ATTACHMENTS SMUSHED
    ________________________________________
    TOTAL SAVINGS1.1 KB / 0%
    ________________________________________
    ATTACHMENTS SUPER-SMUSHED47/248
    ________________________________________
    RESIZE SAVINGS0.0 B
    e
    Thank you for your time
    Sherie

  • Adam Czajczyk

    Hello Robert!

    Please do never post any access credentials here. This forum is publicly visible and fairly well indexed by Google and other search engines so posting login data may cause a serious security threat. I have edited your post and removed them already.

    There's a secure way to let us access your site so could you please grant us a support access by following this guide:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let us know when it's enabled please.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hello Robert,

    Thank you for granting access and I apologize for keeping you waiting. Just for future reference: in case you are granting access to any of your sites, please notify us here as we are not automatically notified about it being enabled. I'm sorry for causing confusion, we should be more specific on that.

    As for the issue. I accessed the site and run "bulk smashing". All images were properly optimized (see screenshot below). There's a couple of files in your site's Media Library that are not images so WP Smush indicates that there's more attachments than the number of files optimized but that's fine as WP Smush can only optimize images.

    There's automatic smushing enabled also so all the images that you will upload to your site in future will also be automatically optimized, without a need to manually run "bulk smushing".

    In case you wanted to change WP Smush optimization settings in future and needed to re-smush images, make sure please that the "Media -> WP Smush" page is kept open in browser while smushing process continues. Bulk smushing doesn't work in background so closing/leaving this page immediately terminates optimization process.

    If you have additional questions, let me know please.

    Kind regards,
    Adam