I have done my

I have done my first quiz using coursepress pro and have had the following complaints:
I hope tomorrow you can check this out for me. Today I had 3 students tell me they were stuck on the web site on the 1st quiz which is in Lesson 5. It wont let them advance.
And one student said her answer was right but the computer kept telling her the answer was incorrect.
Here is the question she referred to:
General Anatomy:

1. The body part of a horse on the topline where the neck ends and the back begins is called the_________.

A. Pastern B. Fetlock C. Gaskin D. Withers

She said the web site was saying the correct answer was B the fetlock and that is not right.
I am asking the other students for what specifics they are having problems with. But mostly what I gather is … it is not giving them a grade and they cant move on to another question or finish the quiz and go on to another lesson.
I will have them send me in writing what sections or issues they are having so you know what exactly is the problem.
But all 3 said they were stuck on the quiz.
So something is wrong. They should be able to take each question even if it is wrong in 2 attempts and keep going.
after I click save and it takes me to the list of lessons. I'm not able to advance onto the next lesson.
I was on section 2 of the quiz and after getting an 85% the first time, I went back to change answers and it wouldn't let me submit the correct answers. But even after I clicked done and went back to the page with the list of lessons it wouldn't advance me onto section 3 of the quiz.
One student just emailed me and said they are stuck in section 2 of the quiz. I don’t know what to do or what to tell them.

    Rupok

    Hi Jeremy,

    Thanks for asking. Let me describe one by one:

    Today I had 3 students tell me they were stuck on the web site on the 1st quiz which is in Lesson 5. It wont let them advance

    Did you try to regenerate this with a test account? I logged in with Support Access, created a test account, enrolled for your course but it seems like there are 11 lessons before lesson 5 and I assume each lesson has around 10 pages. So it will take huge time for me to reach lesson 5. I've written a test user credentials in our Support Staff message section in your site. Can you please login with that user and go to Lesson 5 and check if you can regenerate the same issue? If yes, please let us know. We will check at that point and investigate further. I've checked your Unit 5 page one but nothing seemed to be unusual there. Please confirm if you can regenerate the same issue. And I guess, "Limit Attempts" value is less then the number of her trying. That's why neither she can proceed nor resubmit answer, I'm not sure though.

    1. The body part of a horse on the topline where the neck ends and the back begins is called the_________.

    Can you please mention on which unit and which page I can see this question? I need to check this question from the backend.

    They should be able to take each question even if it is wrong in 2 attempts and keep going

    I checked your Lesson 5 and there, "User also needs to pass all mandatory assessments" checkmark is enabled. Please check the attached screenshot for reference.

    If this option is checkmarked, then your user will not only have to answer all mandatory questions, but also have to give correct answer to proceed. But as you said your users should be able to keep going even if the answer is wrong, I'll suggest you to uncheck that option for all of your lessons. Please correct me if I understood anything wrong. I'll be glad to assist further.

    I was on section 2 of the quiz and after getting an 85% the first time, I went back to change answers and it wouldn't let me submit the correct answers. But even after I clicked done and went back to the page with the list of lessons it wouldn't advance me onto section 3 of the quiz

    Same reason. As 100% of your mandatory answers are not correct, you are not able to proceed. But you should be able to resubmit your answer if your "Limit Attempts" value for that task is more than one. Can you please check that question from the backend and check the "Limit Attempts" value? If it's one, can you please make it 5 and try again?

    even after I clicked done and went back to the page with the list of lessons it wouldn't advance me onto section 3 of the quiz

    When you are taken back to the list of lessons, does it show that section 2 is 100% done but you still can't proceed to section 3? You said you have 85% done. And I believe, that's why you can't proceed. And you are out of your limits for answering. And this creates a loop.

    One student just emailed me and said they are stuck in section 2 of the quiz

    Can you also try to regenerate this? If you can regenerate this, then please stop there and let us know. So we can see the issue live. And then create another test account, enroll to this course and try to go to Lesson 5 and regenerate that issue you mentioned earlier.

    Please let us know how all these goes. If you have any confusion or if you are stuck at any point, please let us know. We will be glad to assist further.

    Have a nice day. Cheers!
    Rupok

    Kasia Swiderska

    Hello Jeremy,

    I still can’t go on to the next lesson on the website. "Quiz in lesson 5 section 2 I'm still stuck on

    I checked that lesson and you haven't checked that there is attempt limit - value is set to 5 but whole option is unchecked.

    Could you follow Rupok instruction from first post about passing course with test user so we could see that issue with question?

    Hey one other thing, I didn't know if there was supposed to be a reset on my password every time I log in.
    However, the website never recognizes my password and I need to reset it every time I log on. Brielle Noah

    Is this message from one of your students? Im not able to replicate that problem on your site with test user account - each time I was able to login.
    It is possible that your student is providing wrong password and that is forcing them to reset it.

    Say they are on lesson 10 and they want to go back and read 5, will they have to go through 6-10 again before they can go on to 11?

    No. As soon as units are completed they are available for re-reading in any order. Student can continue learning in any moment from the unit and page they finished. And also can go back and check previous units without loosing any progress in current units.

    kind regards,
    Kasia

    Jeremy

    OK I have unchecked the box for USER NEEDS TO PASS ALL MANDATORY ASSIGNMENTS and have checked the LIMIT ATTEMPTS, so hopefully that will help. But now have run into this: All of the sudden the website won't let me into Lesson 6. It will let me into Lesson 6 Part 2, but not the first one that just says Lesson 6. Also Brielle Noah is still having to reset her password every time and I don't know why that is.

    Nithin

    Hey Jeremy,

    Hope you are doing good today.

    and now this: I've discovered it's Lessons 6, 11, and 13 that I can't access.

    I suppose this is the issue you are talking about as shown in the screenshot, I'm afraid, this is a bug which has already been reported, and the developer are working on it to provide a fix. At the moment when we check User needs to answer all mandatory assessments and view all pages in order to access the next unit option, users can only continue to their next course if they answer all the correct answers. It' a bug, since the users should have access to the next unit, even if they have given wrong answers.

    I'm marking this thread, so that you would get an update when a fix is released. Will keep you posted, once we have an update on this issue.

    However, when I try to access the units in the CoursePress dashboard page, I'm able to notice that the unit pages for all your lessons aren't visible, and it's only showing a single Image element.

    I'm able to notice, JS conflict in the console:
    Uncaught TypeError: Cannot read property 'fire' of undefined

    Would recommend you to perform a plugin conflict test as illustrated in getting support manual (flowchart), and rule out whether any plugin is causing this issue.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Also Brielle Noah is still having to reset her password every time and I don't know why that is.

    I'm not able to replicate this exact issue in your system. The testuser account what we have, is still working with the same password. Since the issue is related to only one user, this could be an error from the users side. Is it possible, to get a screencast from your user, on how the user is trying to login? What browser did they use? Could you please ask the users to try logging in using a different browser, and check whether it works.

    Please let us know if you still need any further assistance. Have a nice day.

    Kind Regards,
    Nithin