I have enabled GZIP

I have enabled GZIP compression but still get a very low score on compression (38) and a lot of items that should be compressed: Enable compression for the following resources to reduce their transfer size by 1.4MiB (78% reduction).