I have installed and attempted to configure e-newsletter

I have installed and attempted to configure e-newsletter multiple times by following the “usage” tab instructions. However, the “test” buttons and “install” button at the bottom of the setup form do not trigger any action.

When clicked, they simply outline with blue. There is no action or page loading and navigating away from the enewsletter tab in the admin dashboard erases all form data entered.

I have installed the plugin via the wpmudev dashboard and manually. Neither change behavior of the plugin at the setup stage.

Any idea what the issue is? The plugin looks great, but I can’t get it installed/configured.

Note: this may be a problem with all WPMU Dev plugins as the “submit” button on the WMPU dev dashboard support tab within my site also did not work. I have disabled all other plugins and it still did not work.

I updated to the latest version of wordpress before installing e-newsletter. Is there some conflict there? WPMUdev plugins worked before I updated…

  • Alexander
    • DEV MAN’s Mascot

    Hi @digdug,

    I’ve tested this, and it’s working ok for me. There might be some kind of plugin conflict here. There might also be an error message that we can look at.

    Can you try enabling WP_DEBUG mode? To do this, just go to wp-config.php and set WP_DEBUG to true. For example:


    If you’d like to prevent messages from showing to your users, you can enable debug logging. Here’s a code snippet to assist with this: http://git.io/gJANNQ

    Best regards,

  • digdug
    • WPMU DEV Initiate

    I got it to work. Looks like a conflict with some part of “Advanced Stripe Payments Plugin”. Something about this plugin breaks the tab structure of the configuration for e-newsletter. As a result, all of the fields for all sections are on one page, and the tab links work like anchor links. All the fields are there, but the buttons don’t work.

    When I removed the Stripe payments plugin, the tabs worked and the buttons worked. Hopefully I can figure out how to get them both to work. Thanks for your response.

  • Alexander
    • DEV MAN’s Mascot

    Hi @digdug,

    Interesting. Good to hear you were able to track down the conflict.

    What you’re describing Sounds like a problem with javascript files not loading correctly.

    You could try checking the javascript console for errors. It might yield something useful In Chrome go to “View -> Developer -> Javascript Console” and in Firefox you can go to “Tools -> Web Developer -> Console”

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.