i have just installed the WP Smush Pro on my website which

Hi i have just installed the WP Smush Pro on my website which it is an HTTPS side along with the WPMU DEV , but when i go tho the Smush Pro settings the API status saiis "Checking API Status. and it stays there forever.

Any suggestions ? by the way am using this plugin on other 3 websites non HTTPS and it is working perfect.

any help ?

P.S ( what plugin are you using for this forum ? it is fantastic! )

Thanks

Ari

    Ivan

    Hey there Ari,

    Welcome to the WPMU DEV Community!

    Just tested this on my SSL multi site, and there wasn't problems for me.

    This most probably means that your host can't connect to the SmushPro server - my best bet here is to ask your hosting provider if they have firewall, and if they blocked some connections to WPMU DEV.
    The best will be if you can test on another SSL site - on a different host.

    Additionally it wont hurt if you can run a plugin conflict test to see if this is the reason.
    Basically you will need to disable all the other plugins but SmushPro and see if this helps.
    You can refer to the flowchart on this page for more information.

    P.S ( what plugin are you using for this forum ? it is fantastic! )

    As far as I know it is quite old version of BuddyPress with a lot of customization and plugins modified internally.
    And the design is quite new - just couple of weeks old - but that is just the tip of the iceberg.

    Let me know what is your host reposnse.

    Thanks,
    Ivan

    P.S. We have colleague in the team called Ari too. If you have more support questions I am sure you will meet him.

    Michelle Shull

    Hi Ari!

    Our Ari is Greek! Small world. : )

    Okay, if it's not a firewall, let's check out a few other common issues. Are you using Cloudflare? You may need to whitelist the Smush server IP address with them to allow the connection. I also know we've been working with WPEngine, as several of our Smushing members have had similar difficulties there.

    We did recently push an update, have you tried it out yet to see if it resolves your issues?

    And you've got our Dashboard plugin installed, right? It's needed to make the connection to the Smush server.

    Oh - and our forum is actually bbPress. I know, right? Who knew bbPress could be this slick? We've got a team of geniuses who have rebuilt it from scratch, and it looks great, I think. Glad you like it!

    Hope you're having a great week, nuAri!