I have read all forums and no definitive answers to this

Hi, I have read all forums and no definitive answers to this issue "There was a connection problem. Please check the URL and Key of the Master site." I will include log files with domain names stared out. It mentions something about key being wrong but I copy/paste 20 times and still nothing but error. Please Help.

Sub-Domain.log [2014-05-07 02:36:35][M] 0-10 - ajax actions***
[2014-05-07 02:36:35][M] 07 - added new sub site***
[2014-05-07 02:36:48][M] 02 - sending request - url=http://www.**sub-domain**.com/wp-admin/admin-ajax.php?action=user_sync_api;;***
[2014-05-07 02:36:49][M] 03 - sending request - response=0ac2201f9198bbccf2d8ba65a92f5d23;;***
[2014-05-07 02:36:49][M] 06 - checking key false;;***

Master-Domain.log
[2014-05-07 02:36:34][S] 01 - new subsite conection - central_url=http://**Master-Domain**.com;; replace_user=1;; overwrite_user=1;;***
[2014-05-07 02:36:34][S] 02 - sending request - url=http://**Master-Domain**.com/wp-admin/admin-ajax.php?action=user_sync_api;;***
[2014-05-07 02:36:35][S] 03 - sending request - response=
ok;;***
[2014-05-07 02:36:49][S] 0-10 - ajax actions***
[2014-05-07 02:43:50][S] 01 - new subsite conection - central_url=http://**Master-Domain**.com;; replace_user=1;; overwrite_user=1;;***
[2014-05-07 02:43:50][S] 02 - sending request - url=http://**Master-Domain**.com/wp-admin/admin-ajax.php?action=user_sync_api;;***
[2014-05-07 02:43:51][S] 03 - sending request - response=
ok;;***