I have set up a child theme but I am using a RTL template.

I have set up a child theme but I am using a RTL template. The rtl.css style sheet calls a few different files. I made copies of all of those and also copied the file paths to make sure that it worked the same way, but something isn't working. I'm sure this is hard to follow and I can provide FTP access if that will help or WPMU dashboard access.

This is my first time doing child theme's where a style sheet in the parent theme calls more than 1 sheet. I have style.css that calls the parent theme style.css and rtl.css that calls the parent rtl.css

Thank you

  • Michael Bissett

    Hey @ilanaguttman, hope you're doing well today! :slight_smile:

    Could you elaborate as to what isn't working here?

    And could you send in the following, so that we can have a closer look at this:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks a bunch! :slight_smile:

    Kind Regards,
    Michael

  • Predrag Dubajic

    Hey @ilanaguttman,

    Hope you're doing well today.

    I tried accessing your FTP using the details sent but I'm getting an error that the password is incorrect.

    When I inspected your page from browser it seems that all css files are being called correctly.

    From the images you provided I'm a bit confused with which file is called where, I'm not sure if there are any incorrect paths since I can access your files.

    There is also another way you can try to call your css files.
    Use the code below and change the paths and file names. Put the code in your child functions.php files

    function child_add_stylesheet() {
        wp_register_style('name-one', get_template_directory_uri() . '/css/style-one.css');
        wp_enqueue_style('name-one');
    
        wp_register_style('name-two', get_template_directory_uri() . '/css/style-two.css');
        wp_enqueue_style('name-two');
    }
    add_action( 'wp_enqueue_scripts', 'child_add_stylesheet' );

    Hope this helps.

    Best regards,
    Predrag

  • Michael Bissett

    Hey @ilanaguttman,

    When I visited your site again, I noticed that these errors were showing up on the page:

    Warning: include_once(/.../.../public_html/hanakatova/wp-content/themes/flatmarket/iPanel/iPanel.php): failed to open stream: No such file or directory in /.../.../public_html/hanakatova/wp-content/themes/flatmarket/functions.php on line 29
    
    Warning: include_once(): Failed opening '/.../.../public_html/hanakatova/wp-content/themes/flatmarket/iPanel/iPanel.php' for inclusion (include_path='.:/usr/local/php55/pear') in /.../.../public_html/hanakatova/wp-content/themes/flatmarket/functions.php

    When I had first looked at the location in question, the location wasn't there, but then after a few more minutes, it seems like you're working on the site presently, as I noticed that new files were being uploaded.

    Those errors presently keep me from going in to the WordPress admin panel and switching over the theme, and I didn't want to remove the "include_once" statement responsible for generating those errors if you were in the process of re-uploading the theme.

    Could you let us know when you're done with the site please? :slight_smile:

    Kind Regards,
    Michael

  • Ash

    Hello @ilanaguttman

    I have made some modifications in the child theme functions.php and it looks like all the css are loaded from parent theme.

    But it still doesn't look the parent theme. I have checked activating the parent theme and it is using caches. You can find the cache folder from /themes/flatmarket/cache.

    After activating the child theme, you need to configure the settings again I think and this should create new cache. I am not pretty sure if this theme allows caching in child theme, if yes you may need to create a cache folder manually.

    Anyway, do you have any instruction from the theme developer about the child theme?

    Please let us know.

    Cheers
    Ash

  • Ash

    Hello @ilanaguttman

    Well, in a theme, the settings should be saved if you use child theme. About the theme settings in your case, I am not pretty sure. I noticed the theme uses it's own cache system and loads styles from there.

    Would you please just rename the cache folder (/themes/flatmarket/cache) and check if the changes work?

    If not, I would contact the theme developer for instructions to use a child theme for his theme.

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.